Adjusting Auto Bed levelling.

Before I came on board with Repetier, I used Octopi and Klipper and was able to adjust the height of my auto bed levelling within Klipper.

My bed now seems too close to the nozzle and I need to adjust it.

Is there a way I can do that within Repetier? I want to avoid using Marlin in VSCode as it does my head in. I set the printers up many months ago and would rather not have to go back down the VSCode rabbit hole again.

I've also downloaded the latest version of Pronterface, if that helps.

Cheers in advance.


  • You can send any command you want in the console. Do I understand it correctly that you switched Klipper for Marlin?

    One question is if you have auto leveling in marlin configured? I'm not familiar with that on marlin - only prusa has it for my printers and there i send it without commands. The distance to bed when triggering is configured in a lcd menu entry I can change so it is stored in eeprom. So maybe you also have that value in eeprom and just can change it there?
  • Yes. I did the original installation in Marlin, then changed to Klipper.  I was able to easily change the eeprom settings in the Klipper part of Octoprint.

    When I went across to Repetier, I couldn't find any information on using Klipper with Repetier, so I went back to Marlin.  (Eugghh!)  I had to learn how to use VSCode and it was a VERY STEEP learning curve.  I really don't want to ever see a Configuration-H file ever again...

    I changed a nozzle and now the nozzle is too close to the bed. So I 'think' I just need to adjust the Z offset again.  All the videos I've found show the setup from scratch, not the fine tuning.
  • I'm not a marlin pro but that sound like the correct setting. Did you check with M503 if it appears in eeprom settings?
  • In repetier firmware you can change the nozzle to bed distance with 'Z_PROBE_HEIGHT' in eeprom
Sign In or Register to comment.