Generated G-Code Not Found

edited September 16 in Repetier-Host
Hi all,
I have installed Repetier Host on a Raspberry Pi 2 (Revision : a21041/B+, running Raspbian 10/Buster 32 bit).
I downloaded the tar file and ran the configureFirst.sh and the install seems to be OK: I am able to connect to the printer and send commands, BUT the CuraEngine is not working.  When I click the Slice button, it immediately returns with:

Generated G-Code Not F:ound
I could not find the generated G-code file.
Possible reasons:
- the slicer had and an error and didn't finish slicing.  Check log output.
- the slicer stored the file with an unexpected filename.

Expected Filename and location
/home/pi/.local/share/RepetierHost/composition.gcode

I am running a 32 bit OS and I read somewhere that the default install uses a 64 bit CuraEngine.  I see where both the 32 and 64 bit CuraEngines are located in the tar file.  My guess is that it is trying to use the wrong CuraEngine, but I have not found where I can specify it or move it.

I turned on logging in Config / Preferences / Basic Settings: Log Session
and turned off Easy Mode
but I still cannot find any log files in:
/home/pi/.local/share/RepetierHost

Any help would be most appreciated.


Comments

  • Host is not meant to run on arm systems. SO the bundled CuraEngine is for 32 and 64 bit intel processors. You need to find the latest 1.x CuraEngine binary für armhf 32 bit and replace the curaengine with that, then slicer would work and you also get a gcode to load.
  • edited September 17
    Thanks for the help!  After many hours of compiling, I now have a CuraEngine built for the Raspberry Pi.  I copied it to the plugins/CuraEngine folder (and removed all other files).  I tried slicing from Repetier and now I get the following message:

    20:59:31.048 : CuraEngine command:/home/pi/RepetierHost/plugins/CuraEngine/CuraEngine -p -v -c "/home/pi/.local/share/RepetierHost/cura.ini" -s posx=0 -s posy=0 -o "/home/pi/.local/share/RepetierHost/composition.gcode" "/home/pi/.local/share/RepetierHost/composition0.stl"
    20:59:31.064 : Preferred name from fence-standoff3 to fence-standoff3
    20:59:31.119 : <CuraEngine> Cura_SteamEngine version master
    20:59:31.120 : <CuraEngine> Copyright (C) 2020 Ultimaker
    20:59:31.120 : <CuraEngine> This program is free software: you can redistribute it and/or modify
    20:59:31.120 : <CuraEngine> it under the terms of the GNU Affero General Public License as published by
    20:59:31.121 : <CuraEngine> the Free Software Foundation, either version 3 of the License, or
    20:59:31.121 : <CuraEngine> (at your option) any later version.
    20:59:31.121 : <CuraEngine> This program is distributed in the hope that it will be useful,
    20:59:31.122 : <CuraEngine> but WITHOUT ANY WARRANTY; without even the implied warranty of
    20:59:31.122 : <CuraEngine> MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    20:59:31.123 : <CuraEngine> GNU Affero General Public License for more details.
    20:59:31.123 : <CuraEngine> You should have received a copy of the GNU Affero General Public License
    20:59:31.124 : <CuraEngine> along with this program.  If not, see <http://www.gnu.org/licenses/>.
    20:59:31.127 : <CuraEngine> [ERROR] Unknown command: -p
    20:59:31.128 : <CuraEngine> [ERROR] Command called:
    20:59:31.128 : <CuraEngine> [ERROR] /home/pi/RepetierHost/plugins/CuraEngine/CuraEngine [ERROR] -p [ERROR] -v [ERROR] -c [ERROR] /home/pi/.local/share/RepetierHost/cura.ini [ERROR] -s [ERROR] posx=0 [ERROR] -s [ERROR] posy=0 [ERROR] -o [ERROR] /home/pi/.local/share/RepetierHost/composition.gcode [ERROR] /home/pi/.local/share/RepetierHost/composition0.stl [ERROR]
    20:59:31.128 : <CuraEngine> usage:
    20:59:31.129 : <CuraEngine> CuraEngine help
    20:59:31.129 : <CuraEngine>     Show this help message
    20:59:31.129 : <CuraEngine> CuraEngine connect <host>[:<port>] [-j <settings.def.json>]
    20:59:31.130 : <CuraEngine>   --connect <host>[:<port>]
    20:59:31.130 : <CuraEngine>     Connect to <host> via a command socket,
    20:59:31.130 : <CuraEngine>     instead of passing information via the command line
    20:59:31.130 : <CuraEngine>   -v
    20:59:31.131 : <CuraEngine>     Increase the verbose level (show log messages).
    20:59:31.131 : <CuraEngine>   -m<thread_count>
    20:59:31.131 : <CuraEngine>     Set the desired number of threads. Supports only a single digit.
    20:59:31.131 : <CuraEngine> CuraEngine slice [-v] [-p] [-j <settings.json>] [-s <settingkey>=<value>] [-g] [-e<extruder_nr>] [-o <output.gcode>] [-l <model.stl>] [--next]
    20:59:31.132 : <CuraEngine>   -v
    20:59:31.132 : <CuraEngine>     Increase the verbose level (show log messages).
    20:59:31.134 : <CuraEngine>   -m<thread_count>
    20:59:31.134 : <CuraEngine>     Set the desired number of threads.
    20:59:31.135 : <CuraEngine>   -p
    20:59:31.135 : <CuraEngine>     Log progress information.
    20:59:31.135 : <CuraEngine>   -j
    20:59:31.136 : <CuraEngine>     Load settings.def.json file to register all settings and their defaults.
    20:59:31.137 : <CuraEngine>   -s <setting>=<value>
    20:59:31.137 : <CuraEngine>     Set a setting to a value for the last supplied object,
    20:59:31.137 : <CuraEngine>     extruder train, or general settings.
    20:59:31.138 : <CuraEngine>   -l <model_file>
    20:59:31.138 : <CuraEngine>     Load an STL model.
    20:59:31.138 : <CuraEngine>   -g
    20:59:31.138 : <CuraEngine>     Switch setting focus to the current mesh group only.
    20:59:31.139 : <CuraEngine>     Used for one-at-a-time printing.
    20:59:31.139 : <CuraEngine>   -e<extruder_nr>
    20:59:31.139 : <CuraEngine>     Switch setting focus to the extruder train with the given number.
    20:59:31.139 : <CuraEngine>   --next
    20:59:31.140 : <CuraEngine>     Generate gcode for the previously supplied mesh group and append that to
    20:59:31.140 : <CuraEngine>     the gcode of further models for one-at-a-time printing.
    20:59:31.140 : <CuraEngine>   -o <output_file>
    20:59:31.141 : <CuraEngine>     Specify a file to which to write the generated gcode.
    20:59:31.141 : <CuraEngine> The settings are appended to the last supplied object:
    20:59:31.141 : <CuraEngine> CuraEngine slice [general settings]
    20:59:31.141 : <CuraEngine>     -g [current group settings]
    20:59:31.142 : <CuraEngine>     -e0 [extruder train 0 settings]
    20:59:31.142 : <CuraEngine>     -l obj_inheriting_from_last_extruder_train.stl [object settings]
    20:59:31.142 : <CuraEngine>     --next [next group settings]
    20:59:31.143 : <CuraEngine>     ... etc.
    20:59:31.144 : <CuraEngine> In order to load machine definitions from custom locations, you need to create the environment variable CURA_ENGINE_SEARCH_PATH, which should contain all search paths delimited by a (semi-)colon.

    Obviously something is still not configured properly.  Any suggestions would be most welcome!
  • I just realized that CuraEngine didn't work by itself in the plugin folder.  I just overwrote the existing CuraEngine with the one I created.  It still gives the same help message above though
  • edited September 17
    I see where Repetier is calling CuraEngine like this:
    /home/pi/RepetierHost/plugins/CuraEngine/CuraEngine -p -v -c "/home/pi/.local/share/RepetierHost/cura.ini" -s posx=0 -s posy=0 -o "/home/pi/.local/share/RepetierHost/composition.gcode" "/home/pi/.local/share/RepetierHost/composition0.stl"

    and CuraEngine is not happy with the -p parameter:
    [ERROR] Unknown command: -p
    [ERROR] Command called:
    [ERROR] /home/pi/RepetierHost/plugins/CuraEngine/CuraEngine [ERROR] -p [ERROR] -v [ERROR] -c [ERROR] /home/pi/.local/share/RepetierHost/cura.ini [ERROR] -s [ERROR] posx=0 [ERROR] -s [ERROR] posy=0 [ERROR] -o [ERROR] /home/pi/.local/share/RepetierHost/composition.gcode [ERROR] /home/pi/.local/share/RepetierHost/composition0.stl [ERROR] 

    But... in the help it says:
      -p
    Log progress information.


    Note that it is not happy with the -v or -c parameters either.

    I realize this is probably a CuraEngine issue at this point so I have opened another discussion over there.
  • Wrong version. Yours is from 2020 so it can't be the right one.

    08:33:57.766 : <CuraEngine> Cura_SteamEngine version 15.01
    08:33:57.767 : <CuraEngine> Copyright (C) 2014 David Braam

    is what the correct one reports.
    And yes I know it is old - one reason I prefer Prusa slicer in host which is also available for pi or at least able to compile.
  • finally got it working with CuraEngine version 15.0.4.5 from here:
    https://github.com/Ultimaker/CuraEngine/releases/tag/15.04.5

    Any idea when Repetier will support the newer versions of CuraEngine?
  • edited September 17
    So it WAS working fine but I rebooted the pi and now Repetier doesn't see the CuraEngine in the slicer dropdown...  Arrrgggghhhhh
    In fact, there are NO slicers in the dropdown :-(

    I reinstalled repetier and all is well again...
Sign In or Register to comment.