Raspberry Pi4 und Longruner for Raspberry Pi 4 Camera Kamera Module wie konfigurieren

Hallo,
ich habe absolut null Erfahrung mit Raspberry Pi und mit Repetier Server. Ich habe die Kamera mit dem Flex-Flachbandkabel angeschlossen und in der config die Kamera aktiviert. Aber ich habe kein Bild bei "Webcam". Muss ich noch andere Software installieren oder sonst noch etwas einrichten / einstellen?

Bin für jeden Hinweis sehr dankbar.

Gruß Christian

Comments

  • In unserem image ist alles drin damit sie automatisch läuft. Hast du deinem Drucker eine webcam hinzugefügt und dann unten aus der Liste die pi webcam ausgewählt und zugewiesen? Dann siehst du ja das die 2 url Felder ausgefüllt sind und solltest ein Bild sehen.

    Gerne wird aber das zuweisen oder gar hinzufügen der webcam zum Drucker vergessen weil sie ja unten sichtbar ist.
  • Guten Morgen,

    ich habe im Internet zwei mögliche Installationsvorgehen gefunden. Entweder nur das Repetier-Image auf die SD-Karte kopieren und fertig, oder zuerst ein Raspberry OS installieren und dann die Repetier-Software per Terminal installieren lassen. Im Moment läuft die zweite Version, weil ich mit der Ersten Version nicht auf die Einstellung der Konfiguration " Kamera -> aktivieren" kam.

    Eine webcam habe ich hinzugefügt, bekomme aber keine Liste aus der ich etwas auswählen kann. Ich kann nur Webcam Verbindung auswählen und zwei URLs eingeben (beide URLs sind leer). Darunter sind noch die 4 Kamerasymbole zur Orientierung der Lage. 
  • Die automatische Erkennung geht nur mit dem Image weil wir da den mjpg_streamer mit entsprechender Konfiguration mit drauf haben. In deiner 2. Version musst du das alles leider selber installieren (mjpg streamer) und konfigurieren. Aber dazu haben wir auch eine Anleitung unter docs auf unserer Webseite.

    > Im Moment läuft die zweite Version, weil ich mit der Ersten Version nicht auf die Einstellung der Konfiguration " Kamera -> aktivieren" kam.
    Warum nicht? Selbst wenn keine webcams erkannt wurden ist die Option da. Gleiche stelle wie in variante 2 nur halt mit den Webcams unterhalb der 4 icons.

  • Ich habe vorhin das Image installiert. Dann eine Webcam hinzugefügt. Die PI aus der Liste (eh nur 1 Eintrag) ausgewählt, zugewiesen. Die beiden URL http://127.0.0.1:9000/?action=stream bzw. snapshot sind automatisch eingefügt worden. Es wird leider nichts angezeigt, nur das Symbolbild bei snapshot, unter der stream-URL ist nichts. Kein Symbolbild, nichts.

    Repetier said:
    > Im Moment läuft die zweite Version, weil ich mit der Ersten Version nicht auf die Einstellung der Konfiguration " Kamera -> aktivieren" kam.
    Warum nicht? Selbst wenn keine webcams erkannt wurden ist die Option da. Gleiche stelle wie in variante 2 nur halt mit den Webcams unterhalb der 4 icons.
    Nein, war nicht da. Nicht unter den 4 Icons oder sonst wo. Hätte ich das vorher gewusst, hätte ich ein screenshot gemacht.
  • > Ich habe vorhin das Image installiert. Dann eine Webcam hinzugefügt. Die PI aus der Liste (eh nur 1 Eintrag) ausgewählt, zugewiesen. Die beiden URL http://127.0.0.1:9000/?action=stream bzw. snapshot sind automatisch eingefügt worden. Es wird leider nichts angezeigt, nur das Symbolbild bei snapshot, unter der stream-URL ist nichts. Kein Symbolbild, nichts.

    Hört sich von der Vorgehensweise richtig an. Auch url ist richtig. Wenn nur das Standardbild gekommen ist liegt es vermutlich daran das der mjpg_streamer aus irgend welchen gründen beendet wurde. Auf der Serverseite ist damit alles korrekt gewesen. Wenn der Streamer läuft kannst du auch über
    http://ip:9000
    die webseite des mjpg_streamers sehen. Wenn da nichts kommt läuft er nicht mehr und du solltest untersuchen warum das so ist. Per ssh einloggein und
    tail -1000 /var/log/syslog
    nachdem du im server einmal restart servers geklickt hast. Das startet sie neu dann sind die einträge im log ziemlich weit unten. Hast du eine andere Auflösung gewählt als die Standardauflösung? Wenn eine nicht unterstützt wird stoppt er wieder.
Sign In or Register to comment.