Mal wieder am Repetier testen mit kleinen aber nervigen Problemen

Hoi
ich teste mit meinem Prusa Mk3s incl. MMU2s mal wieder den Rep Server da ich ihn eigentlich cool finde.
Aber ich habe scheinbar ein paar Konfig Fehler drin denn ich kann mir nicht denken.
Ich nutze von Prusa den aktuellen Slicer und die aktuelle Firmware.
Nun zu den Problemen:
  1. habe ich immer wieder das Problem das der Drucker zwar aufheizt aber in auf dem Repetier steht noch immer aööes auf rot und geht mit der Temp nicht hoch. (ich meine das löst Problem 2 aus)
  2. Filament laden, er versucht das Filament und der physische Teil ist noch nicht warm genug und somit zieht er das Filament zurück, er macht aber nicht wie im Original Modus ein 2. oder 3. versuch er bleibt stehen.
  3. Temp Nozzle und Bed 23-50° wenn ich den Server reboote sehe ich die richtige Temp. Auch beim Druck stoppen geht die Temp nicht mehr runter sondern friert ein.
  4. Was sicher ein Konfig Problem ist, die Drucke mit gleichem gcode sind wesentlich schlechter mit dem Repetier im Gegensatz zum Octo. Drucker einstellungen habe ich vom Thread https://forum.repetier.com/discussion/7985/prusa-mk3-i3-with-mmu2s-setup/p1 übernommen. Bisher habe ich immer gelesen das mit Rep die Drucke besser aussehen. Sobald ich den Drucker über den Repetier mal wieder zum laufen bekomme Poste ich mal 2 Benchy damit ihr seht was ich meine.
Derzeit ist Drucken Remote nicht möglich, ich muss zuhause immer alles kommplett abklemmen x mal neu starten bis der Druck und Anzeige wieder richtig läuft.

Möchte dieses Mal nicht gleich wieder  zum Octo wechseln sondern gucken ob man was verbessern kann.
Nebenbei lese ich mich mal schlau wie ich meine MyStrom Steckdose abschalten kann, bisherige gefundenen Lösungen sind zu umständlich noch nicht das was ich suchen. Meine Schaltdose ist für den PI incl. Drucker. Also nahc dem Print 10-15min abkühlen, Repetier herunterfahren udn 2min später Steckdose abschalten. Das ganze muss man per knopfdruckt ändern können, denn wenn ich viele Teile nacheinander drucke will ich ja nicht immer das er abschalten. Das im gcode verankern ist kein gültiger weg, da ich dann jeden Code so kennzeichnen müsste das dieser abstellt. 
Aber ich bin ja auch noch nicht fertig mich lesen ;)

Vielleicht hat die Community zu meinen Problemen ja ne Idee, das wäre schon hilfreich.

GRüsse
Heiko

Comments

  • edited September 10
    So habe gerade die Version 0.94.3 gesehen und installiert. Nun scheint 1-3 erledigt zu sein. Zumindest konnte ich nun einfach ein Druck starten :) Edit leider nur einmal, jetzt startet wieder nichts mehr, trotz Hotend und Bed auf Power off geht die Temp nicht runter. :(
  • Grundsätzlich ist die Konsole dein Freund beim debuggen. Nur da siehst du was server sendet und firmware antwortet und ob die überhaupt reden. Ist nicht immer selbstverständlich da der prusa auch mal die Kommunikation blockiert bis du am display etwas entschieden hast. Spätestens nach einem druck auf die reset taste am prusa sollte die Kommunikation wieder klappen.

    Mit Steckdose den pi abschalten über eine Funktion auf dem pi geht zwar aber ist nur eine Frage bis die sd Karte defekte bekommt. Du weist ja nicht ob er grad eine wichtige Datei schreibt oder wie du ihn erwischt. Insbesodnere wenn die karte intern mit wear leveing beschäftigt ist fangen Probleme an.

    Es gibt jetzt ein shutdown script. Du kannst dieses script mit einem timeout ausführen lassen oder nur wenn du im Druckermenü es aktiviert hast - dann wird es aber sofort nach Druckende ausgeführt. Müstest also evtl. verzögerungen da einbauen
    G4 S120 ; 2 Minuten warten
    @syncMotion
    @webAction deinRunterfahrWebCall

    4. Ist untypisch da wir deutlich schneller mit dem Drucker kommunizieren können. Hier mal im log nachsehen ob da Kommunikationsfehler vorkommen. Das ist eigentlich der einzige weg den Server auszubremsen. EVtl. falsche Baudrate eingestellt? 234000 und 250000 klappen meist beide aber einer macht viele Fehler.
  • Repetier said:
    Grundsätzlich ist die Konsole dein Freund beim debuggen. Nur da siehst du was server sendet und firmware antwortet und ob die überhaupt reden. Ist nicht immer selbstverständlich da der prusa auch mal die Kommunikation blockiert bis du am display etwas entschieden hast. Spätestens nach einem druck auf die reset taste am prusa sollte die Kommunikation wieder klappen.

    Mit Steckdose den pi abschalten über eine Funktion auf dem pi geht zwar aber ist nur eine Frage bis die sd Karte defekte bekommt. Du weist ja nicht ob er grad eine wichtige Datei schreibt oder wie du ihn erwischt. Insbesodnere wenn die karte intern mit wear leveing beschäftigt ist fangen Probleme an.

    Es gibt jetzt ein shutdown script. Du kannst dieses script mit einem timeout ausführen lassen oder nur wenn du im Druckermenü es aktiviert hast - dann wird es aber sofort nach Druckende ausgeführt. Müstest also evtl. verzögerungen da einbauen
    G4 S120 ; 2 Minuten warten
    @syncMotion
    @webAction deinRunterfahrWebCall

    4. Ist untypisch da wir deutlich schneller mit dem Drucker kommunizieren können. Hier mal im log nachsehen ob da Kommunikationsfehler vorkommen. Das ist eigentlich der einzige weg den Server auszubremsen. EVtl. falsche Baudrate eingestellt? 234000 und 250000 klappen meist beide aber einer macht viele Fehler.
    Ja ich muss mal gucken woran es liegt, vom Büro aus ist immer nervig. Laut log hat er komuniziert aber irgendwas scheint nicht korrekt gewesen zu sein. Hatte nun alles 2h aus und nach dem Neustart läuft alles wie gewollt los, interessanter Weise macht er gerade die Purge line nicht, er fährt sie zwar ab und scheint auch fördern zu wollen aber es kommt nix raus. Da muss ich nochmal schauen woran es liegt.

    Das mit dem Shutdown Script muss ich nochmal schauen eingetragen ist es, muss man immer noch die extcommands.xml editieren? Muss mal mein PW raussuchen der PI user hat ja keine rechte dort :)

    zu 4. ja das meinte ich auch, werde es am Benchy nachher direkt vergleichen können, bei mir ist Standard 115200 drin. Kann es ja mal pushen.
  • Pi user kann alles wenn man sudo voranstellt:-) sudo -i macht dich auch zum root.

    115200 baud ist kein Problem. Aktiviere mal logging beim druck.

    Hast du eine schnelle sd Karte? Langsame führen manchmal zu aussetzern weil linux dann auf schrieben warten könnte.
Sign In or Register to comment.