Repeatability and Stability

Hello!  So for the last week or so I have been playing with Repetier Server connected to a rumba controller with Repetier firmware .91.  The Repetier-Server lives on a Rasperry Pi.  My process to install everything was:
  1. Load fresh Raspbian release onto SD card, power up Raspberry Pi, raspi-config, update rpi...
  2. Load wifi adapter driver and get wifi working
  3. Build Repetier-Server accorting to the install.txt from the github repository
  4. Create a cfg with my printer configuration, something like this:

  slugName="3dprinter"; // Unique name with ascii chars without space,tab. Is used for path names.
    //baudrate=250000; //
    pingPong=false; // Allow sending more then one command if it fits into printer cache
    readCacheSize=127; // Size of the printer cache. May be 63 for some printer.
    /* Communication protocol used to communicate with this printer:
       0 = ascii protocol - works with all reprap firmwares
       1 = Repetier-Protocol V1 - requires Repetier-Firmware
       2 = Repetier-Protocol V2 - requires Repetier-Firmware 0.80 or higher */
    okAfterResend=true; // Does your firmware send a ok after sending a resend for that line?
    xhome=0.0; // Coordinates after homing x axis
    yhome=0.0; // Coordinates after homing x axis
    zhome=0.0; // Coordinates after homing x axis
    xaxis=50.0; // Move speed in mm/s for manual moves
    yaxis=50.0; // Move speed in mm/s for manual moves
    zaxis=2.0; // Move speed in mm/s for manual moves
    eaxisExtrude=2.0; // Move speed in mm/s for manual moves
    eaxisRetract=20.0; // Move speed in mm/s for manual moves
    count=1;  // Number of extruder on that device
    tempUpdateEvery=1; // Update temperature every x seconds
    heatedBed=false; // Has heated bed (true) or not (false)

I was able to get the server to run, move the machine, run commands, upload files, etc.  I am even able to send some jobs.  Unfortunately I cannot get the system to print jobs the same way, and I get different behavior.  Therefore the system does not provide a repeatable operation.  Some of the behaviors I get while running jobs:

  • Job runs ok, no issues
  • Job runs, but stutters as - if - you - were - speaking - with - a - pause - between - every - word
  • Job runs but stops at some seemingly random point, usually RX/TX lights on the board are going crazy and are typically fully on

Please note, this does not happen when the machine is connected directly to a Windows 7 x64 computer running Repetier-Host 1.0.3 (jobs run as expected, same gcode files).  I would really appreciate some help in trying to get to the bottom of why this is happening, and perhaps trying to narrow down the problem.  I've tried some things, like changing some of the parameters in the .cfg file like readCacheSize, but the behaviors are the same.  The repeatability issues started appearing when I was trying to print a longer gcode file appx 3mb).  I've only had this file 'print' fully one time out of 10+ tries.  I have a smaller file (appx 300kb) that has a better success rate, but from time to time has issues.

I've tried to give as much info as possible, but I can understand that this is not such a technical report.  So anything I could try to gather more technical information that would lead to an answer, please let me know!


Sign In or Register to comment.