Pro Licence REquired

Hi Repetier,

I'm playing some more with the server, trying to get the touch interface running on a Beaglebone Black with 4.3" LCD Cape.

It is a tight squeese, but that is the LCD's fault.

The bug I'm getting is that, sometimes the rendering shows "Licence Required PRO", and sometimes it shows the rendering as expected.

I know that this will be a PRO feature in the future, but now the server can not decide if it is Pro or not. :)

Thank you,


  • What version are you using. With 0.60.0 I had this also several times and 0.60.1 has improved this. In the main interface I got it sometimes when teh websocket was not established but disappeared once it got connected. In 0.60.2 I have some more improvements with the interface, but that needs to be published.

    BTW: What did you use as full screen browser and do you have a black square on the left upper corner? I tried with kweb and somehow x server/kweb has that square always in that place and I can not find out what causes it.
  • Using 0.60.1

    Using kweb, but I had to totally mangle the css to get everything to fit, more or less. Only have the first tab's screen, no tabs, no logo. But no black square.

    I have found though that setting the screen height/width the same as my screen causes scroll bars to appear, horizontal and vertical. I have to set the screen height to 254, instead of 272. I loose 18 pixels off the bottom, but no scroll bars.
  • You could set overflow:hidden for the element creating the scrollbars. Have the same problem with the pi display. Sometimes I get scrollbars sometimes not. Had this already in fullpage but then I guess body creates them. For next update I also set this in body tag. Better then loosing pixel.
  • I saw the overflow:hidden suggestion on the net, applying it to *. But I have no idea here to put it, don't know anything about html, and less about css.

    BTW, how do you fit it on the pi display? What did you throw away? :)
  • I will test my overflow suggestion for body for next release. Just doing some final tests on design.

    My pi display is a 7 inch 1024x600 pixel so there was nothing to throw away. The default templates are desgined for 7+ inch displays. For smaller displays you would make a more nested design with more levels to fit it. I think we will publish a smaller design as well in the future.

    What resolution and size does your display have?
  • Ahh, I thought you where talking about the smaller 3.2" Pi display.

    By beaglebone has a 480x272 display.

    But i'm considering buying a 7" 800x480 hdmi touch screen display for a pi and using that instead. Already tried and everything fits nicely at that resolution. It's just bigger and harder to fit on a printer. :)
  • Ok, have uploaded new server and there the scrollbars are gone in my resolution. Putting it in body tag as well helped here to convince the browser.
  • Thanks, that solved the scroll bar problem.

    Still getting the "License Required" issue though.

    Only getting it on the touch interface. Not getting it on the full web interface.

    Getting it the problem if touch interface is opened from PC browser or from kweb running on beaglebone...

    BTW, running server armhf, if that helps...
  • Just to be sure - we are talking about the icon graphics showing "Pro" not having the complete display with a simple pro message? Just got the pro images once and after reload they were gone. So I assume this is the case. Since the server was already running for a while it should know better.
  • edited June 2015
    Yesterday I only got this images. Even after the server ran a while. But on the full website, clicking on the "eye" then selecting 3D, it shows corrently. But that also has in the past sometimes shown the same "Pro License Required"


  • Ok, found the problem with the graphics. Depending on timing of network, multithreading etc, the ordering of connection commands could change to a wrong order. Is fixed in next release. After 200 reloads no errors seen :-)
  • Great news! :)
  • edited July 2015
    BTW: What did you use as full screen browser and do you have a black square on the left upper corner? I tried with kweb and somehow x server/kweb has that square always in that place and I can not find out what causes it.
    Hi Repetier,

    I don't know if you have solved this black square, but I found the solution on the net somewhere. It is caused indirectly by fbi that you use to show the splash screen. It is a text cursor. :)

    If you add this to the asplashscreen script, i added it right before the fbi line, then the black block will be gone:
    echo 0 > /sys/class/graphics/fbcon/cursor_blink

    BTW, I now have a 5" LCD on my PI, with a 800x480 resolution. It makes fitting things on the screen SO much easier.

    Edit: Found it in the comments here:

    Thank you,

Sign In or Register to comment.