How to resume a print after @pause line

edited August 27 in Questions & Answers
Hello,

I very recently switched to Server from Host.
When I used Host, there was a popup window whenever I had a @pause line and I was able to resume with the gui button. 

I can't find any resume button with Server anywhere. How can I resume my print? 
I also tried to directly send the websocket command continueJob after @pause
It didn't work either. (All the other commands were working. Even stopJob worked but continueJob did not resume the print.

Could you let me know where I can find the Resume button.
I also need to use continueJob. Could you let me know why continueJob doesn't work?

Thanks!

Comments

  • continueJob works same as stopJob so if one works both should work. But there is a case where you need to send it twice. When you have configured server to cool down extruder after some period and that happened the first continue will just heat up and only the second continue will then continue the job.
  • Repetier said:
    continueJob works same as stopJob so if one works both should work. But there is a case where you need to send it twice. When you have configured server to cool down extruder after some period and that happened the first continue will just heat up and only the second continue will then continue the job.
    I send it twice. Still not working. Only stopJob works. I don't know the difference between @pause and stopJob. I assume it does the same thing under the hood. Then, is there a gcode command like @pause but resume the print ex. @resume

    Instead of using stopJob - continueJob pair,
    I would like to send @pause and "resume" gcode to my printer. 

    Is there such a command? 
  • Nevermind, it's working, but I have another question.

    So when I send @pause, the machine runs a few seconds until executing @pause.
    I wonder if there is a way to make the pause quicker. For instance, regulating the number of lines in the queue so that there are not many lines waiting in front of @pause. Do you have any advice for that? Thanks.
  • No you can not shorten pause. What you see are the moves buffered inside printer firmware to optimize path planning and to protect for short delays. You can reduce that in firmware but that might also reduce print quality if you go below some value. When depends on type of print. Mainly curved models need higher buffers.


  • Sounds like worth trying. 
    Could you elaborate how to reduce the buffer size in firmware? 
    What parameter should I tweak? 

    Also, could you let me know how that's related to the printing quality?
    I assume it's because the path planning is not optimized, but it's it predetermined in sliced/ready-to-print gcode? 
  • How depends on the firmware - it is the motion buffer size I speak off.

    And no, it is not predetermined in slicer. Slicer tells what speed it wants but firmware decides what you get. The maximum speed you get is the one that allows deceleration to 0 if no new moves get added since exactly that will then happen. So if you want 100mm/s and it takes 10mm to decelerate and you only have 5mm it will print at 50mm/s. If that comes from low buffer printer will continously accelerate/decelerate which has big impact on quality.
  • edited September 1
    Thanks for clarifying. I tried to find a buffer size parameter in EEPROM, but couldn't find it.
    I dropped the input buffer size from Connection to 63 from 127 which shortened the amount of time to actually pause the machine. I was unable to drop the buffer size lower than 63. 

    From what I read in this Forum, the default buffer-size config is 16. That sounds like it's different from the connection buffer size. Where can I find the parameter and how can I change the value if it's not in EEPROM.

    Thanks.

    update_

    Looks like 127 is the right value as the default changed from 16 to 127.
    If that is the case, is there a way to lower it even below 63 as the repetier-server does not allow it?
    Also, when it's lowered to 63, it's saying the value is not matching the firmware setting. 

    Still the same question I guess then..., how can I change the value in the firmware setting?
  • You need to recompile firmware to change motion buffer size. That parameter can not be changed in eeprom.

    The input buffer size is something different and used to send multiple commands in parallel until it is full. This speeds up data transfer which is important with small moves. Or it delays a timeout on missing "ok" responses. Of course it might also add a tiny delay in addition but nothing compared to the 16 or 32 buffered lines.
Sign In or Register to comment.