Printer Configuration Wizard: Stuck on step one

I type in the printer name and click "Continue with Step 2" and nothing happens for a at least 5 minutes. I click "Continue with Step 2" one or two more times and wait. Then I click Abort. After a couple seconds, its aborted, but then I see that 2 or 3 printers have been added, all with the same name.

If I go to Actions, then Printer Settings, nothing happens. Same with "Go to Printer." I try to go to http://localhost ... /NewPrinter/general (because that is where "Actions" then "Printer Settings" tries to go to, but nothing happens.

Has this happened to anyone else, and how did you fix it?


  • By the way, I have installed the armel 0.60.1 on the pi 2. I started with octoprint on the sd card, then downloaded the armel .deb file from repetier-server downloads page to the pi's download folder and ran 
    sudo dpkg -i xxxxxx.deb 

    I got two messages saying 
    adduser: The group `intserial' does not exist.
    adduser: The group `ugpio' does not exist.

    Oh and before installing the .deb file, I had ran "sudo apt-get update" and "sudo apt-get upgrade" 
  • I restarted and it works now :) 

    Should have tried that before posting
  • I suspect that this is in fact a bug.

    I also can't get to step 2. The printer does appear in the main page, but you can't open it.
    After a reboot you can open the printer...
  • Will try to reproduce it. We had problems when the printer was not connected as the port list never came whcih was needed to continue. But that should be fixed. Maybe it is a problem with permissions. Also the installer puts the user into the right groups, the starting shell might not believe it until reboot, which is why it works after reboot. As both of you now said after reboot it works and server is still the same I think it is more something permission related. Does the /var/lib/RepetierServer/logs/server.log contain any messages? Since my installations are long in use I guess I will not see the error and having success.
  • I don't know if this might be related?
    2015-03-01 22:53:21: error accessing /printer/layeranalysis/Big?id=1&sess=%5EmpVk9%23v%24vMc9k8MQp8FjgtJuS0n2wML: Unknown printer

    Thank you,

Sign In or Register to comment.