Raspberry Pi Zero W connection troubles (0.94.2)

Trying to connect my MKS Sbase v1.3 to Repetier Server installed on mentioned RPi via WiFi.
The connection between RPi and PC has a strange behaviour:
after adding the printer in the web-interface the window with "Connection lost! OOps..." starts to appear and disappear every 1-2 seconds.
Printer connection icon is usually as "disconnected", sometimes changes to "connected" (rarely).
Repetier Host's connect button - blinking connected/disconnected the same way.
I've tried:
 - Connect via Putty-ssh - it has a stable connection with RPi.
 - Separate power connection by sealing the +5 contact of data USB cable with electric tape.
 - Tried to find usr\local\Repetier-Setup\bin\manageWiFi file or something similar - no way, the only screensaver file is in there.
 - Check undervoltage via web-interface and RPi console - neither undervoltage nor throttling events registered.
 - If I mount SD card of MKS board into the RPi filesystem the card looks OK, I'm able to manage config file via putty.
 - Yesterday I've launched "sudo apt-get update", "sudo apt-get upgrade" (mostly to check if putty has rapid responce on the RPi actions) with following reboot and miracle occured: it worked during rest of night until I power it off. Today I switch it on and have the same sympthoms again. 
- Remove the printer profile from Repetier Server - conection problems go away. Add printer again - connection trouble window blinks again.
May I try something else?

P.S. Google Chrome is unable to display Repetier Server web-interface on 3 different devices with Win 7 and 10 - the only blank white screen appears. Chrome mobile and Firefox are OK. IExplorer 11 shows the mixed up tiles of top toolbar - unable to use.


  • First have a look at /var/lib/Repetier-Server/logs/server.log or server.log.0 depending on which is active. Sounds like the printer configuration somehow crashes the server and you see it restart and crash again.

    I develop it using chrome as reference browser, so that in general works great. Maybe related to your restart problem getting not all files. If you open chrome debugger and reload you would see in network if downloading files fail or if there is a javascript error.

    It can also be a corrupt sd card. Had that on my pi zero several times and then anything can happen and new writes like your update can make a change that helps for a while.

    PS: Always shutdown pi bevore unpowering!
  • Thanks for heading my way of shooting the trouble:
    checked server.log and found the cyclic intializaton/disconnection -> during the covid break I forgot that the firmware on my "smoothie" I had replaced with marlin one before... That had been firmware conflict. Changed the firmware type in Rep-Server settings to marlin - got OK.

    Chrome slill not work, regardless I've reburned the image, reinstalled Repetier package, checked the SD-card for badblocks (0 found). 
    Is here a sense to post the debug information here? Maybe open new thread?
  • On chrome enable development tools->networking and reload. Do same in firefox and see which file fails to load. Eventually check also console. Since firefox works network and server should be ok. Maybe also try in private mode. I'm not sure if extensions are disabled there, but that is what the test intends for. If all chromes know you all have same extensions so if one is causing trouble it will hapen on all your computers.

    Normally I'd also say disable firewall but firefox gets it so it's not firewall blocking traffic I guess.
  • You support are real monsters here: completely correct - the plugin Megabonus (cashback system) leads to an error. 
    Seems I'm going to buy Pro licence to support the project, despite I don't need it's full functionality.
    My respect.
Sign In or Register to comment.