Unable to connect to printer after Upgrade to 0.94.2

edited August 23 in Repetier-Server
Hi there,

after upgrading from 0.94.1. to the latest 0.94.2, my 2 printers (SKR 1.4 Turbo and without Turbo) were immediately offline, and I could not connect again. When I switch on / off my printers, I can see the marlin ports appear and disappear, however, choosing them does nothing.

Any tipps for debugging?

Btw, my raspberry Pi, with which I connect to my printer, can still access the SD card on my SKR board, so I am now trying to flash a previous firmware. So the printer serial port is visible to my pi.

Thx,

Michael

Comments

  • edited August 23
    Ok, I just changed RTS / DTR from "LOW to HIGH" to "HIGH to LOW", and it could connect. Didn#t expect that to change between version  :#
  • Hi thanks. I had the same issue. Changed RTS/DTR to high to low and now it works.
    I‘m using the SKR mini E3.
  • We changed order for new configurations but existing ones should keep the old settings. But looks like high->low works on more printers then the other way around so guess we are going back for next release with defaults.
  • I had the same problem with Marlin 2.0.5.3.  The workaround listed by the others worked for me.  Running standard Mega with RAMPS.
  • Can confirm the same here with both an Ender 3 and 5, both running SKR v1.4 boards.  Both had this error in Console "Dtr: false Rts: false repetier".  Changed RTS / DTR from "LOW to HIGH" to "HIGH to LOW" and both connect up fine now.
  • edited August 25
    I have the error too.
    1) skr 1.3 + FIRMWARE_NAME:Marlin 2.0.5.3. - HIGH to LOW - OK
    2) mks gen + Marlin 1.1.9 - It does not connect any way!
    3) skr mini v1.1 with + Marlin 2.0.5.4 - HIGH to LOW - OK
    4) mks gen l + repeiter-firmware 0.92.9 - work ok default

  • Same here: SKR 1.4 Turbo w/ Marlin 2.0.6 stopped working after upgrading. Changing configuration to "HIGH to LOW" fixed the problem.
  • Repetier said:
    We changed order for new configurations but existing ones should keep the old settings. But looks like high->low works on more printers then the other way around so guess we are going back for next release with defaults.

    Instead of waiting for the next release, why not releasing an immediate fix ?

  • If I realease all known issues should be fixed on all 7 supported os.
  • edited August 30
    I have same problem and even if I change to high-low, connection is no longer stable on my skr 1.3 . Old settings are there but problems. It worked perfectly until the update. Now printing from SD-card. Don't know how to fix it.
  • I have a prusa mini where I need to deactivate ping pong to be able to connect.
    I'm currently testing and searching the reason so I can make a update soon.

Sign In or Register to comment.