having problem installing Repetier Host 2.16 on Linux Mint

Dear Team,
I've been using Repetier Host for five years and know by experience that this is is the most practical and user-friendly 3D printing host of all. Very recently I switched my desktop computer Lenovo ThinkCentre from Windows 7 to Linux Mint. Linux Mint was a dream made true until I tried to install my downloaded files of Repetier Host 2.16. It was always easy to do it on Windows XP, 7 or 10.
To be honest, I don't have a clue about how to do it. My Linux Mint is already upgraded. 
Any help or suggestion will be greatly appreciated.
Sincerely,
Victor

Comments

  • Normally you should install the appimage version as that contains all required software. It might still fail to work due to some missing package. To see if something is missing start it from a shell you see the output. Then you easily see if some library is missing and all you need to do is installing the library mentioned. If you find one is missing pleas elet me know and I might be able to add it in next version by default. 
  • Belated thanks for your kind answer. Could you please tell me which shell should I use to find out which library or package I'm missing in order to make Repetier applmage version on Linux Mint 20.
  • Just open a terminal windows - shell is not relevant which, but guess you get bash. Then just start the app from the terminal window and you see all output.
  • This is what i got. Definetely something is missing here.
    -bash: Repetier-Host-x86_64-2.1.6.AppImage.tar.gz: command not found
    victor@victor-ThinkCentre-M58p:~/Downloads$ Repetier-Host-x86_64-2.1.6.AppImage.tar.gz
    -bash: Repetier-Host-x86_64-2.1.6.AppImage.tar.gz: command not found
    victor@victor-ThinkCentre-M58p:~/Downloads$





  • The downloaded file should have name Repetier-Host-x86_64-2.1.6.AppImage  without tar.gz. Only the non app image version has that extension.
  • I made sure that it is in downloads. something continues missing. Should I download it and extract again?

    victor@victor-ThinkCentre-M58p:~/Downloads$ Repetier-Host-x86_64-2.1.6.AppImage
    -bash: Repetier-Host-x86_64-2.1.6.AppImage: command not found
    victor@victor-ThinkCentre-M58p:~/Downloads$



  • When you are in Downloads check file
    ls -l

    it could be that you did not add execute permissions to the file:
    chmod a+x Repetier-Host-x86_64-2.1.6.AppImage

    Without that it is not an executeable and would not run.
Sign In or Register to comment.