Can't Connect The Laptop To Repetier Host, it got disconnected soon?

Hello everyone, thank you for your hard work.
We would like to inquire about a scenario wherein the laptop device can't connect to the Repetier Host? It got connected at first but then after few seconds it got disconnected and even the software crashed and got closed instantly. 

The laptop that was used was: Lenovo P52 and the specs are as follows:
Processor: Intel(R) Core(TM) i7-8850H CPU @2.60 GHz 2.59 GHz
Installed memory (RAM): 16.0 GB (15.7 GB usable)
System type: 64-bit Operating System, x64-based processor
Pen and Touch: Pen and Touch Support with 10 Touch Points

We tried to right down manually what we could see from the logs and it showed something like:
Fast VBOs for rendering not supported. Using slower default method. 
echo: Free Memory: 2680 PlannerBufferBytes: 1232
echo: M301 P43.68 f1.06 D449.22
echo: cannot open subdir
Could you kindly help  figure out the issue why the laptop is not connecting to the printer? We tested the software to 3rd laptop (Lenovo T490) and it worked fine.


  • You need to check the logs a bit more up where it says which OpenGL driver gets used. My guess is that it switched to Microsoft generic driver which is a very old standard and instable so it is known to crash the host.
    Some laptops select driver based on power settings reduce power consumption. Or you just need to update to a newer opengl driver. Or set display performance to 100%.

    Alternative solution is to use Repetier-Server to send the gcode. That is a better solution anyway as it is a background daemon not using opengl or anything else fancy. Host can connect with it and send the print job. When host crashes the print would still continue if run over server connector.
Sign In or Register to comment.