Printer won't move after latest upgrade to Raspberry Pi image

Upgraded my Repetier Server Pi Image to the latest version and now the printer won't move!  It seems to send commands and get responses but the printer just sits there and does nothing.

It was working fine with no issues with version 0.92.  After upgrading to the new 0.94.0 build when I send a command I get errors like...
Recv:16:17:37.444: ok
Recv:16:17:37.444: Slow command added:G28 Y0
Send:16:17:37.444: Resend: N16 G28 Y0
Recv:16:17:37.451: Error:Line Number is not Last Line Number+1, Last Line: 10
Recv:16:17:37.451: Resend: 11
Recv:16:17:37.460: ok
But the printer is not moving at all.

I followed these instructions...
https://www.repetier-server.com/knowledgebase/upgrade-to-our-latest-pi-image/

Everything seemed to go very well during the migration to the new version.  It just won't control the printer now...  Any ideas?

Comments

  • The part shows a problem but is too short to see e problem. The problem started a bit up i think and you need to know why it started to get errors and what was send to earn that error and also if it got fixed by resending or if it started a resend loop with no correction. Here i see resending line 16 but prolem was already in line 11 so that seems to be the problematic one.

    which firmware are you using? Mk4due had a bad entry and you should update - not sure if i fixed that one in 0.94.1 or 0.94.2 beta which you can install only manually by changing download link to that version.
  • edited July 16
    Here is the entire log from the boot of the printer...
    Mesg: 9:07:19.927: Connection started
    Mesg: 9:07:19.928: Dtr: false Rts: false
    Mesg: 9:07:19.938: Dtr: true Rts: true
    Recv: 9:07:20.860: start
    Recv: 9:07:20.860: echo:Marlin 1.1.6
    Send: 9:07:20.860: N1 M110
    Send: 9:07:20.860: N3 M115
    Recv: 9:07:20.860: echo: Last Updated: 2017-10-10 12:00 | Author: (RepRapGuru Prusa i3 V4,11/27/17)
    Recv: 9:07:20.862: echo:Compiled: Jan 20 2018
    Recv: 9:07:20.862: echo: Free Memory: 4023 PlannerBufferBytes: 1232
    Recv: 9:07:20.867: echo:Hardcoded Default Settings Loaded
    Recv: 9:07:20.867: echo: G21 ; Units in mm
    Recv: 9:07:20.869: echo: M149 C ; Units in Celsius
    Recv: 9:07:20.869: echo:Filament settings: Disabled
    Recv: 9:07:20.870: echo: M200 D3.00
    Recv: 9:07:20.870: echo: M200 D0
    Recv: 9:07:20.870: echo:Steps per unit:
    Recv: 9:07:20.876: echo: M92 X80.00 Y80.00 Z4000.00 E90.00
    Recv: 9:07:20.876: echo:Maximum feedrates (units/s):
    Recv: 9:07:20.880: echo: M203 X250.00 Y250.00 Z2.00 E22.00
    Recv: 9:07:20.880: echo:Maximum Acceleration (units/s2):
    Recv: 9:07:20.880: echo: M201 X1000 Y1000 Z5 E1000
    Recv: 9:07:20.884: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    Recv: 9:07:20.884: echo: M204 P500.00 R500.00 T750.00
    Recv: 9:07:20.892: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    Recv: 9:07:20.893: echo: M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z0.40 E5.00
    Recv: 9:07:20.893: echo:Home offset:
    Recv: 9:07:20.895: echo: M206 X0.00 Y0.00 Z0.00
    Recv: 9:07:20.895: echo:Material heatup parameters:
    Recv: 9:07:20.895: echo: M145 S0 H180 B70 F255
    Recv: 9:07:20.896: M145 S1 H225 B100 F255
    Recv: 9:07:20.898: echo:PID settings:
    Recv: 9:07:20.898: echo: M301 P22.20 I1.08 D114.00
    Recv: 9:07:23.368: ok
    Send: 9:07:23.436: N4 M220 S100
    Recv: 9:07:23.438: echo:Unknown command: "its in m37"
    Recv: 9:07:23.438: ok
    Send: 9:07:23.438: N5 M221 S100
    Recv: 9:07:23.444: Error:Line Number is not Last Line Number+1, Last Line: 2
    Recv: 9:07:23.444: Resend: 3
    Recv: 9:07:23.454: ok
    Send: 9:07:23.454: Resend: N3 M115
    Send: 9:07:23.454: Resend: N4 M220 S100
    Recv: 9:07:23.469: FIRMWARE_NAME:Marlin 1.1.6 (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:REPRAPGURU PRUSA i3 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    Recv: 9:07:23.469: Cap:EEPROM:0
    Recv: 9:07:23.469: Cap:AUTOREPORT_TEMP:1
    Recv: 9:07:23.472: Cap:PROGRESS:0
    Recv: 9:07:23.472: Cap:PRINT_JOB:1
    Recv: 9:07:23.473: Cap:AUTOLEVEL:0
    Recv: 9:07:23.473: Cap:Z_PROBE:0
    Recv: 9:07:23.473: Cap:LEVELING_DATA:0
    Recv: 9:07:23.473: Cap:SOFTWARE_POWER:1
    Recv: 9:07:23.474: Cap:TOGGLE_LIGHTS:0
    Recv: 9:07:23.475: Cap:CASE_LIGHT_BRIGHTNESS:0
    Recv: 9:07:23.475: Cap:EMERGENCY_PARSER:0
    Recv: 9:07:23.476: ok (2)
    Send: 9:07:23.476: Resend: N5 M221 S100
    Send: 9:07:23.476: N6 G92 E0
    Recv: 9:07:23.479: ok
    Send: 9:07:23.479: N7 G90
    Send: 9:07:23.479: N8 M82
    Recv: 9:07:23.483: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv: 9:07:23.484: ok (3)
    Send: 9:07:23.484: N9 G21
    Send: 9:07:23.484: @getip
    Recv: 9:07:23.488: ok
    Send: 9:07:23.489: N11 M155 S1
    Recv: 9:07:23.496: ok
    Send: 9:07:23.496: N12 M117 192.168.46.47:3344
    Recv: 9:07:23.508: Error:No Checksum with line number, Last Line: 11
    Recv: 9:07:23.508: Resend: 12
    Recv: 9:07:23.519: ok
    Send: 9:07:23.519: Resend: N12 M117 192.168.46.47:3344
    Recv: 9:07:23.537: Error:No Checksum with line number, Last Line: 11
    Recv: 9:07:23.537: Resend: 12
    Recv: 9:07:23.546: ok
    Recv: 9:07:27.956: echo:SD init fail
    Send: 9:07:34.947: @getip
    Send: 9:07:34.950: N13 M117 192.168.46.47:3344
    Recv: 9:07:34.959: Error:Line Number is not Last Line Number+1, Last Line: 11
    Recv: 9:07:34.959: Resend: 12
    Mesg: 9:07:34.959: Resend after 11450ms
    Recv: 9:07:34.969: ok
    Send: 9:07:34.970: Resend: N12 M117 192.168.46.47:3344
    Recv: 9:07:34.978: Error:No Checksum with line number, Last Line: 11
    Recv: 9:07:34.978: Resend: 12
    Recv: 9:07:34.986: ok
    Send: 9:07:34.986: Resend: N13 M117 192.168.46.47:3344
    Recv: 9:07:34.993: Error:Line Number is not Last Line Number+1, Last Line: 11
    Recv: 9:07:34.994: Resend: 12
    Recv: 9:07:35.002: ok
    Does that help?  It shows the firmware of the printer I'm using too.  Should I still try to upgrade to the beta?  If so, how do I do that with the Raspberry Pi image install?  Do I need to download a beta Pi image or can I just upgrade the software to beta from CLI or better yet can it be done via the Repetier-Server Web GUI?

    -UPDATE-
    Just a heads up I found the area to update via the Web Gui and I noticed there was a new Repetier-Server stable build to download (ver 0.94.1).  I downloaded it and did an auto-install.  I guess it worked because the update screen now shows "You are already using the latest version.".  However, the build number at the top still shows "0.94.0" when I would expect it to show "0.94.1".  (Not important but some feedback...  If I open the web GUI up in an incognito window it shows the correct version number.  So that tells me it's some type of caching issue.  I tried to reload the non-incognito window with Ctrl+F5 for a clean reload of the page but that did not work either.)  My question above about the updating was specifically about the BETA BUILD if you wanted me to try that. 
    Repetier said:
    not sure if i fixed that one in 0.94.1 or 0.94.2 beta which you can install only manually by changing download link to that version.
    I didn't understand this comment (quoted above).  What do you mean when you say "by changing download link to that version"?  How do you do that?

    Thanks!
  • edited July 16
    [removed - does not seem to be an option to delete a post]
  • edited July 16
    [removed - does not seem to be an option to delete a post]
  • Ok the problem is with M117 and the fact that marlin changed several times how to handle it. It should get send without linenumber and without checksum. You can‘t see that in the console and need a real log to see it. Anyhow that is fixed i think.

    What i mean with changing download link is to copy the link on our download link and replace the version number in it and download 0.94.2 manually to install it as described for first installation on linux. Since it is not official you can not use the autoupdate function until it is released. It fixes a problem you might have when a print is finished, but not all have it. And it might contain the fix to your special problem also i think 0.94.1 has fixed. Or does it still fail after connect?
  • Yes, it still fails after connect.

    I was looking at everything trying to understand all the pieces of the puzzle called 3d printing.  In doing so I noticed that my printer uses the Marlin 1.1.6 firmware.  Currently, on https://github.com/MarlinFirmware/Marlin I see the latest release is Marlin 2.0.5.4.  That is quite a jump from my current version.  Should I upgrade my printer's firmware to that latest version?  Or do you think I should use a different firmware?  OR...  Should I NOT upgrade the firmware?

    If upgrading Repetier Server to version 0.94.2 beta will not help the issue I'm having (where I turn on the printer and raspberry pi, it shows connected in the Repetier Server Web GUI but when I go to control and home everything nothing happens) then I would rather not use the beta version.  From your response, I'm not sure that upgrading to the beta build will help me with my issue though.  If you think it will please let me know and I will give it a shot.  But first, I want to see if upgrading the old firmware will help so please give me your advice on that more than anything.
  • edited July 16
    I was digging into it some more and I'm starting to really understand how it all works.  I realized it was an error on that line 12 (aka N12).  That line was "Send: 9:07:23.496: N12 M117 192.168.46.47:3344".  Then there was a response to that "Recv: 9:07:23.508: Error:No Checksum with line number, Last Line: 11".  That is telling me the error and then the last successful line sent was line 11 (aka N11).

    After understanding that and looking up G-Code M117 I found that was an issue trying to set the LCD settings!  It just so happens one little tiny thing I changed RIGHT AFTER I FINISHED THE UPGRADE was that little dang setting (Printer Settings>Connection>Show on Printer LCD Status Line).  I changed it from "Rotate" to "Show ETE" just so the remaining time was shown on the LCD.  I figured that was an improvement and was happy with myself.  Then I ended up shooting myself in the foot because there was an issue with it right out of the gate!  LOL, I think that might have actually been the ONLY thing I changed too...  :/

    Anyway, so I changed the setting back to "Rotate" then saved the settings and unplugged the USB cable from the Pi and plugged it back up (keeping in mind the actual printer in unplugged at the moment so I can kill the power to the mainboard).

    Now I have this current log...
    Send:19:30:40.528: N7 G90
    Send:19:30:40.528: N8 M82
    Recv:19:30:40.529: X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    Recv:19:30:40.529: ok
    Send:19:30:40.530: N9 G21
    Send:19:30:40.530: @getip
    Recv:19:30:40.539: ok (3)
    Send:19:30:40.540: N11 M155 S1
    Recv:19:30:40.548: ok
    Send:19:30:40.548: N12 M117 192.168.46.47:3344
    Recv:19:30:40.557: Error:No Checksum with line number, Last Line: 11
    Recv:19:30:40.557: Resend: 12
    Recv:19:30:40.568: ok
    Send:19:30:40.568: Resend: N12 M117 192.168.46.47:3344
    Recv:19:30:40.601: Error:No Checksum with line number, Last Line: 11
    Recv:19:30:40.601: Resend: 12
    Recv:19:30:40.610: ok
    Recv:19:30:45.022: echo:SD init fail
    Send:19:30:52.006: @getip
    Send:19:30:52.008: N13 M117 192.168.46.47:3344
    Recv:19:30:52.014: Error:Line Number is not Last Line Number+1, Last Line: 11
    Recv:19:30:52.017: Resend: 12
    I even tried to disable the LCD option all together but I get the same results.  So now I'm not sure what could be the problem.  I figured that turning it off would fix it but maybe the way you handle that command on the old firmware is completely different in newer f/w versions.  Since I'm running a really old one it might not be sending the correct commands for the old version.

    So my next steps...  I think I have read up enough and feel good about upgrading to the new Marlin f/w 2.0.5.4.  Hopefully, when I do that and load up the Repetier Server again it will play nice with my new firmware.

    Also, because no commands can be issued using raw commands in Repetier Server because the firmware locks and new commands because a bad one was sent on line 12, I'm going to use the old SD card I kept a copy of (pre Repetier-Server upgrade).  This way I can run commands like "M503" to copy the old settings into a file for later use.
  • First there is no need to upgrade firmware when everything was running. I‘m wondering that 0.94.2 still makes the m117 trouble. Your firmware description contains a line to remove line numbers from it so it should not have a line number at all when being send to prevent just that error. I can tell you how to not send it it at all. Disable lcd output where you found it is a good step but at start there is a line @getip which also sends ip number to firmware using m117. You need to remove it from connection commands. Login via ssh shell and go to
    /usr/local/Repetier-Server/firmwares
    then 
    sudo nano marlin.xml
    maybe it is Marlin.xml
    search the line with @getip and remove it and then save and restart server. Then it should connect fine.
    Will check on the issue when I‘m back and wonder why the other others using marlin don‘t seem to have the problem. I know I added problem that in mk4due firmware description But marlin was not a problem so far.

    Do you have marlin selected as firmware in connection config? Because e.g. reprapfirmware has no problems with it so we send it there with line numbers, so feason can also be a wrong selected firmware.
  • I just finished upgrading the firmware (before your post).  I needed to upgrade anyway.  I was still running the old custom firmware that was shipped with the printer (Marlin v 1.1.6).  I upgraded to Marlin 2.0.5.4.  I just finished doing all the tweaking to it (to make the steppers move in the correct direction etc).  Everything seems OK so far except the time it takes to heat the bed up.  For some reason on 2.0.x it's taking a LOT longer to heat the bed.

    Just checked on the Firmware selected in the settings and I was using RepRapFirmware.  Is that a lot different?
  • So it looks like that error is now gone since I'm using the correct firmware type in the settings.  Interestingly enough, I always had it set to that while using the old version of Repetier-Server and it worked fine.  I even popped the old SD card back in the Pi that was running the old server and it worked fine again.  The latest version seems to have the issue.  However, it was my fault for not choosing the correct firmware in the first place.  Amazing it's been working all this time.  I just needed to learn a little more about what I was doing and it became clear.  Thanks for pointing it out btw!

    One last issue I have...
    With the new firmware and server upgrade everything now seems to be working (even the bed is heating up quickly since I disabled "//#define PIDTEMPBED" in the Merlin config.  The only thing that is not working is when I set a temp on the bed and extruder the heating range is so far off.  Ex: I set an extruder temp of 180 and it never stays at 180.  It keeps going from 174ish to 185ish.

    See the following image as an example.
    https://ibb.co/7K3647n

    Any ideas why?
  • Yes, as i said marlin has the line number problem, reprapfirmware not so they are handled differently. Also some commands differ so selevting right firmware is essential.

    Your temperature problems are firmware problems. Reason is that your PID values are not calibrated well. Guess you had other values on previous version that worked better. There is a autotune command - i think M303 to find better parameter, see marlin docs for options.
  • Thanks for the reply Repetier.  I posted this on reprap.org trying to find a solution as well...

    https://reprap.org/forum/read.php?406,875120

    I have posted the original firmware config used (Marlin 1.1.6) as well as the newly upgraded firmware config used (Marlin 2.0.5.4).  You can see in there I used the same values (default) for the PIDTEMP config.
    // Ultimaker
    #define  DEFAULT_Kp 22.2
    #define DEFAULT_Ki 1.08
    #define DEFAULT_Kd 114
    Just ran the auto-tune command...
    Recv:14:10:07.020: PID Autotune start
    Recv:14:13:50.719: bias: 66 d: 66 min: 196.25 max: 204.29 Ku: 20.92 Tu: 45.36
    Recv:14:13:50.719: Classic PID
    Recv:14:13:50.720: Kp: 12.55 Ki: 0.55 Kd: 71.15
    Recv:14:13:50.723: PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
    Recv:14:13:50.724: #define DEFAULT_Kp 12.55
    Recv:14:13:50.724: #define DEFAULT_Ki 0.55
    Recv:14:13:50.726: #define DEFAULT_Kd 71.15
    Recv:14:13:50.726: ok
    Interesting how the last flash was able to achieve homing in on the target temp for the extruder so well given the values were so far off.

    I have updated those values in the config and recompiling them now.  Then after the reflash and another test I'll post back the results.

    Also, I tried doing the same for the bed using the config setting:
    #define PIDTEMPBED
    When that is turned on it takes FOREVER for the bed to heat up and the autotune on it fails.  Any ideas what I can do there to make that successfully give me results I can fine-tune bed heating with?
  • Well, looks like there were a few settings in the Configuration_adv.h file I needed to adjust as well...

    #define THERMAL_PROTECTION_HYSTERESIS 7
    changed to
    #define THERMAL_PROTECTION_HYSTERESIS 4

    and

    #define THERMAL_PROTECTION_BED_HYSTERESIS 4
    changed to
    #define THERMAL_PROTECTION_BED_HYSTERESIS 2


    Seems like that would make a big difference.  Before changing these values and flashing again, when running the tests my printer reached about 87 degrees and sounded an alarm then shut off.  I'm hoping the tests I'm currently running turn out better now.

  • I ended up running the following command to fine-tune my heated bed...
    M303 E-1 S90 C8

    It ran for about 10 minutes and then tossed me the following error...

    Recv:17:24:53.292: PID Autotune failed! timeout

    I found out that I needed to get the temp near my target for testing (90 degrees) first.  Then I could run the test and get back the following results...

    Send:17:25:56.221: N15 M303 E-1 S90 C8
    Recv:17:25:56.226: PID Autotune start
    Recv:17:33:18.143: bias: 235 d: 19 min: 89.89 max: 90.17 Ku: 173.54 Tu: 22.61
    Recv:17:33:18.143: No overshoot
    Recv:17:33:18.144: Kp: 34.71 Ki: 3.07 Kd: 261.58
    Recv:17:33:39.282: bias: 233 d: 21 min: 89.89 max: 90.17 Ku: 191.81 Tu: 21.13
    Recv:17:33:39.282: No overshoot
    Recv:17:33:39.284: Kp: 38.36 Ki: 3.63 Kd: 270.26
    Recv:17:34:00.094: bias: 235 d: 19 min: 89.89 max: 90.17 Ku: 173.54 Tu: 20.81
    Recv:17:34:00.094: No overshoot
    Recv:17:34:00.094: Kp: 34.71 Ki: 3.34 Kd: 240.73
    Recv:17:34:21.891: bias: 234 d: 20 min: 89.89 max: 90.17 Ku: 182.67 Tu: 21.79
    Recv:17:34:21.891: No overshoot
    Recv:17:34:21.891: Kp: 36.53 Ki: 3.35 Kd: 265.38
    Recv:17:34:45.323: bias: 232 d: 22 min: 89.89 max: 90.17 Ku: 200.94 Tu: 23.43
    Recv:17:34:45.324: No overshoot
    Recv:17:34:45.326: Kp: 40.19 Ki: 3.43 Kd: 313.86
    Recv:17:35:05.318: bias: 232 d: 22 min: 89.89 max: 90.17 Ku: 200.94 Tu: 19.99
    Recv:17:35:05.318: No overshoot
    Recv:17:35:05.319: Kp: 40.19 Ki: 4.02 Kd: 267.76
    Recv:17:35:05.322: PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
    Recv:17:35:05.323: #define DEFAULT_bedKp 40.19
    Recv:17:35:05.323: #define DEFAULT_bedKi 4.02
    Recv:17:35:05.325: #define DEFAULT_bedKd 267.76
    Recv:17:35:05.325: ok

    So I'm going to try and use these new values in my firmware configs and see how that does.

  • Also, just to add it...  To fine-tune the extruder I first got my extruder to about 190 degrees then used the command...
    M303 E0 S200 C8
    I got back the following results...
    Send:17:46:40.742: N18 M303 E0 S200 C8
    Recv:17:46:40.747: PID Autotune start
    Recv:17:49:55.126: bias: 66 d: 66 min: 196.25 max: 204.02 Ku: 21.64 Tu: 43.75
    Recv:17:49:55.126: Classic PID
    Recv:17:49:55.126: Kp: 12.98 Ki: 0.59 Kd: 70.99
    Recv:17:50:38.711: bias: 66 d: 66 min: 196.64 max: 204.20 Ku: 22.24 Tu: 43.58
    Recv:17:50:38.712: Classic PID
    Recv:17:50:38.715: Kp: 13.35 Ki: 0.61 Kd: 72.70
    Recv:17:51:21.810: bias: 65 d: 65 min: 196.88 max: 203.57 Ku: 24.72 Tu: 43.09
    Recv:17:51:21.810: Classic PID
    Recv:17:51:21.813: Kp: 14.83 Ki: 0.69 Kd: 79.88
    Recv:17:52:06.218: bias: 64 d: 64 min: 196.25 max: 203.57 Ku: 22.26 Tu: 44.40
    Recv:17:52:06.218: Classic PID
    Recv:17:52:06.218: Kp: 13.36 Ki: 0.60 Kd: 74.13
    Recv:17:52:50.625: bias: 65 d: 65 min: 196.25 max: 203.57 Ku: 22.61 Tu: 44.40
    Recv:17:52:50.626: Classic PID
    Recv:17:52:50.626: Kp: 13.56 Ki: 0.61 Kd: 75.28
    Recv:17:53:33.556: bias: 65 d: 65 min: 196.84 max: 203.79 Ku: 23.79 Tu: 42.93
    Recv:17:53:33.560: Classic PID
    Recv:17:53:33.560: Kp: 14.27 Ki: 0.66 Kd: 76.58
    Recv:17:53:33.564: PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
    Recv:17:53:33.565: #define DEFAULT_Kp 14.27
    Recv:17:53:33.565: #define DEFAULT_Ki 0.66
    Recv:17:53:33.567: #define DEFAULT_Kd 76.58
    Recv:17:53:33.567: ok
    Thanks for all the help getting me set.  I think my biggest issue aside from the wrong firmware selection in the Repetier-Server printer settings was the values I needed to change in the advanced config file listed in my previous post.  I think I'm all good now and about to run my first test print since upgrading the Marlin firmware and Repetier-Server software.
Sign In or Register to comment.