0.94 not working with MK4duo

Update from 0.92.3 to 0.94.1 no more work with MK4duo. Using firmware MK4duo the connection with printer don't work anymore. Experimented continue time out and errors.
Also with RepRapFirmware no more work.
with 0.92.3 work perfectly with RepRapFirmware (MK4duo was not in list). With Marlin firmware can connect and is able to Home axis, but print stop after a while.
Retrned to 0.92


  • Ok for the mk4duo I tested with 4.4.0 and it worked but had some problems with M117 so I needed to add
    <bugfix name="FORBIDE_N" command="M117" />
    to the firmwares/MK4duo.xml file right after "<busyHandling>relaxed</busyHandling>". Then M117 worked again without problems.

    Connecting to a RepRapFirmware on a duet had nor problems. Did you have a printer with that or was that just a test for you mk4duo?

  • Sorry, I Make a totally new installation (I don't want to loose my 0.93 working system) But there is no way to connect tu Rumbs 32 with MK4duo.
    This happens in 3 different installation of 3 different people wit 3 different main board (also in a 2560 with Ramps 1.4)
    Selecting Marlin software connect, but a lot of commands are different and deadlock the firmware.
    I needed to write a special installation manual for raspberry: installation of 0.94 image, download of 0.93 package, transfer and replacement of 0.94.....
    There is the option of download a 0.93.1 Image ?
    PS I can't find any xml file in MK4duo sketch
  • Please try the 0.94.2 beta there I have already fixed the missing line. Just download the linux version you need by replacing the version in download link with 0.94.2
    The file it self is in /usr/local/Repetier-Server/firmware/ folder.

  • Ok, after some test, seem to work.
    I suppose that the update in settings menu work.
Sign In or Register to comment.