Timelapse captures first image then no more

I'm running Repetier Server Pro 0.93.1 on a RPi4 with 2 webcams.

As the title states, regardless of how I set up my timelapse (webcam 1 or webcam 2 or both, image at layer, height, time, etc), it shows as "capturing" during my print, but at the end, it only captured a single frame before the print started. If I force position for the frame, the printer moves to that position as planned on every layer, but still the final output is just a single image from before the print started.

Any assistance would be much appreciated.


  • Please check if your sd card is nearly full. There is a test to not overflow sd card and recording stops early to prevent problems with full sd card before it happens.
  • Repetier said:
    Please check if your sd card is nearly full. There is a test to not overflow sd card and recording stops early to prevent problems with full sd card before it happens.
    It's a 32GB card, but interestingly, my PC only sees it as a 90MB capacity through Windows explorer. That doesn't seem right...does that mean I need to reflash the image?
  • Ok that explains it. Question is how big is the main partition. So put it in your pi and login via ssh.
    and you should get something like this:

    pi@Felix:~ $ df

    Filesystem     1K-blocks    Used Available Use% Mounted on

    /dev/root       30564532 5400028  23900256  19% /

    devtmpfs         1966332       0   1966332   0% /dev

    tmpfs            2000124   15236   1984888   1% /dev/shm

    tmpfs            2000124   25084   1975040   2% /run

    tmpfs               5120       4      5116   1% /run/lock

    tmpfs            2000124       0   2000124   0% /sys/fs/cgroup

    /dev/mmcblk0p1     92742   53198     39545  58% /boot

    tmpfs             400024       0    400024   0% /run/user/1000

    Important is here / folder. On windows you only see the /boot drive and that has 90mb free so that is ok. Ir only contains the boot kernel. Also in server home screen you see the free capacity of your main drive.

    If you make many timelapses it is easy to fill the sd card. The new version 0.94.1 has an option now to delete the images once the video was created. This reduces the memory usage on disk a lot. Just in case you need to clear some disk space. Of course deleting complete timelapses reduces even more.

  • Alright, checked the disk space through ssh and it looks like I should be fine for timelapse. Any other ideas what could be causing this?

    Here's my current disk usage.

    I neglected to mention, I have successfully done timelapses in Repetier Server, but then it suddenly stopped working.
  • Also, I just updated to 0.94.1 and tried again...same problem.
  • You need 500MB free space or it will not store image and that is in deed the case here.

    Do you have for static images the url

    port may vary. If you have the mjpg url in static that would never stop capturing, but would also give a big file.

    Last thing to check is server.log - if anything goes wrong while taking a snapshot it should contain a message:

    error taking snapshot: ....

    With Repetier-Server Monitor you can see then contents of syslog directly otherwise in web gui of 0.94.1 you can also download it.

  • Alright. Tried a test print after updating, fixed position timelapse every layer. Showed as capturing during print, printhead moved to appropriate location each layer, but only 1 pic in timelapse from before print start. vid was 1 second long and showed only that frame.

    Here's log for that print:
    2020-06-28 09:26:06: Connection started: |||P Maker Select
    2020-06-28 09:26:06: Reset printer |||P Maker Select
    2020-06-28 09:27:01: Websocket opened
    2020-06-28 09:31:52: Job created: /var/lib/Repetier-Server/printer/P_Maker_Select/jobs/00000001_PLA-25Cube.u
    2020-06-28 09:31:52: finish job creation /var/lib/Repetier-Server/printer/P_Maker_Select/jobs/00000001_PLA-25Cube.u
    2020-06-28 09:31:52: start printjob PLA-25Cube on printer |||P Maker Select
    2020-06-28 09:31:52: Added timelapse 20200628T093152_PLA-25Cube_1
    2020-06-28 10:09:57: Print of PLA-25Cube on printer |||P Maker Select finished. Send 35805 lines. Printing time: 0:38:05
    2020-06-28 10:09:57: /usr/bin/ffmpeg -loglevel error -f concat -i input.txt -c:v libx264 -filter_complex [0:v]transpose=1 -threads 3 -r 30 -pix_fmt yuv420p -profile:v baseline -level 3.0 -movflags +faststart -b:v 1000k -y video.mp4
  • In general settings there is a new function to delete images after converting to video that is enabled by default. It is in timelapse settings. At the moment I'm running some test prints to see if that is all working correctly for counter testing.

    Settings were correct in that tab and if you see it moving to capture position the settings there should also be ok.
  • Ok I'm through testing. With or without special position and with or without automatic image removal all worked as supposed.

    When you delete one webcam does it still not work? Maybe it is a problem with you having 2 webcams.

    When you manually add 

    in console during print it should also add an image.

    Will also now run a test with 2 webcams.
  • I tried deleting one webcam, and then using the @make_snapshot command you referenced, but it doesn't look like a snapshot was taken. Where would I look to see the image?
  • Even with both webcams capturing same time it works.

    A corrupt sd card can also cause such strange effects but it not very likely that on every try the folder will only store the first image. The only other thing that would make sense is that fetching new images fails after the first one. But I never had this and you would then also not see the webcam while printing.
  • Ok, I found the issue. I managed to fix it, then get it to break again. 

    I have 1 usb webcam and 1 PiCam connected directly to the board. I removed both and unplugged them. Then, I added each one back in one at a time and tested the timelapse. It worked on both. What messed it up was trying to record a timelapse on both cameras at the same time. The usb camera captured 3 frames then stopped, the PiCam didn't capture anything, and all of my following attempts afterwards led to a single frame and nothing else (my original problem). Removing them both and adding them back in one at a time worked.

    The lesson: I can't record on both at the same time.
  • Ok that is some progress, but in general it is possible to use 2 webcams the same time. I did for the test also it was 2 usb webcams and in one test 2 times the same pi cam.

    Which resolution do you use?

    Could it be that the webcam software crashes if both are queried the same time? Also check the bolt icon in gui - if it gets orange or red you have a power problem which can cause any kind of problems. And having 2 webcams requires more power then one alone. So what I want to say 2 webcams work but only if both mjpg_streamer instances stay working and it might be that one of them crashes when you use both and knowing the pi power is a likely reason which is why we added the bolt menu so you can see if you have problems with it.
  • Both cameras are set at 640x480 and 10fps. If I click into the bolt icon, it currently says "Underpowered: Never" but I can try another dual timelapse and see what happens. In the past, I have gone into the webcam settings and selected "Restart wecbam server" and that did not fix the problem. As I said, once it goes wrong, it doesn't get right again until the cameras are deleted, physically unplugged, then plugged back in and added back into the server.

    I have some other usb webcams...maybe I'll also try doing dual timelapse with 2 usb's and see if the same thing happens. 
  • And, of course, this time it worked. Both cameras captured images through the end of the print and created a video.
  • When it stops working login via ssh and run
    ps aux | grep mjpg

    to see if you still have 2 streamers running or if they did quit. As long as they are there capturing should work. But if they stop for some reason then you need to find the reason. mjpg_streamer logs data to /var/log/syslog (also downloadable in server logs). So maybe it gives you a hint when it is the steeamer being stopped.

    At least your last success show that in general it works and the question is just what is preventing it sometimes.
Sign In or Register to comment.