[0.94.0] Server restarts (pi) and printers stop

edited June 2020 in Bug Reports
I been printing 24/7 for over 1 year and never had this issue , today I did the update to the latest (0.94.0) and now printers work for about 2hours and then they stop, I can't access the server from the browser and I have to manually reset the power from the pi in order to work again, I have this issue on all 4 of my Raspberry pi's ( each one have 4 printers) any idea of what is causing this issue? I never had this before the update.

I notice that one of the printer right before it stops on the screen it says "sleep"

Please help !



  • Did you upgrade server or image?
    I have surely not programmed a sleep mode in server, so only thing I can think of is that a screensaver now thinks it needs to shutdown linux into sleep mode. Can you say how the sleep message looked like? Did it appear in the interface or more like it came from another system part?

    Will test a bit more with new image to see if it happens also for me.

    One thing to test would be go to screensaver in touch gui and disable it. If it then stops for you it is clear that it comes from screensaver and I need to check why this suddenly happens.
  • I just registered on one printer that the screensaver script /usr/local/Repetier-Setup/bin/screensaver had 0 byte after an update. Is this also the case for you?

    Would changing content to the intended content:


    # Implements commands
    # screensaver on - Called when screensaver should activate
    # screensaver off - Called when screensaver should be inactive
    # screensaver config <0/1> <time> - Set time for screensaver. <0/1> enables/disable function.

    export LC_ALL=C
    DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
    cd $DIR

    case $CMD in
        # Add code to run on screensaver activation
        if [[ -e "/dev/backlight-1wire" ]]; then
            echo 0 > /dev/backlight-1wire
        # Add code to run on screensaver deactivation
        if [[ -e "/dev/backlight-1wire" ]]; then
            echo 80 > /dev/backlight-1wire
         export DISPLAY=:0
         if [[ "$P1" == "0" ]] ; then
            xset s off
            xset -dpms
            xset dpms 0 0 0
            xset s noblank
            xset s reset
            echo "Screensaver disabled"
            xset s on
            xset +dpms
            xset dpms 0 0 $P2
            xset s blank
            xset s $P2
            echo "Screensaver enabled"

    Make the problem disappear?
    The 2 lines 
            xset dpms 0 0 0
            xset dpms 0 0 $P2

    are new compared to old version which was to solve screensaver not working for some users due to new buster behaviour.
Sign In or Register to comment.