Trying to customize the RS Touch frontend


to be honest it's far beyond my knowledge, but still gave it a try. 
I followed the instructions at ( but got stuck when trying to compile.

It cancels with the following error message:

ERROR in Cannot determine the module for class MyDashboardComponent in /home/pi/Desktop/RSTouchscreenNG/src/app/mydashboard.component.ts! Add MyDashboardComponent to the NgModule to fix it.

To give it a first try I just deleted the "Restart UI" Line in mydashboard.component.ts and don't know what to do anymore. Hoping it's an easy fix someone can tell me how to solve it. 


  • Actually easy is not the right term here. You should be familiar with npm, angular and the problems of versions. Please wait for next release. There I have updated all dependencies to work with current versions correctly. So it might be easier. Will at least test myself it it works out of the box with the commands in the docs after releasing.
  • Fair enough! Sounds like a good way to go for. 
    Any estimate when the next version will be out?

  • It is more or less finished. Just some tweaks to mak eit work on more armv7 processors and testing the new image then it will be published. So hope next week to be through with all this.

  • first of all: the new interface for movements is great! 

    I tried to work my way trough a custom ui today (I admit: a lot of trial and error) and everything looked great until I came back to check a few minutes back and saw this error message:

    Compiling @angular/router/testing : es2015 as esm2015

    Compiling @angular/common/http/testing : es2015 as esm2015

    Compiling @angular-redux/store/testing : es2015 as esm2015

    Compiling pages : es2015 as esm2015

    ERROR in main-es2015.js from Terser

    Error: Call retries were exceeded

        at ChildProcessWorker.initialize (/home/pi/RSTouchscreenNG/node_modules/terser-webpack-plugin/node_modules/jest-worker/build/workers/ChildProcessWorker.js:191:21)

        at ChildProcessWorker._onExit (/home/pi/RSTouchscreenNG/node_modules/terser-webpack-plugin/node_modules/jest-worker/build/workers/ChildProcessWorker.js:268:12)

        at ChildProcess.emit (events.js:198:13)

        at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)

    [17:48:21] 'compileAppProd' errored after 3.85 h

    [17:48:21] Error in plugin "gulp-shell"


        Command `ng build app --prod` failed with exit code 1

    [17:48:21] 'prod' errored after 3.94 h

    any ideas? Else I belive I'll live with it the way it is or get someone to work out something that is 100% the way I want it. 
  • No idea what the reason is. The error is inside a compile part and not a syntax error of our sources. You would need to google the error for terser-webpack-plugin to get an idea. It might be a problem with the node version. I used the current node 12 LTS release for my compilations on a mac where it worked.
  • I suppose my biggest mistake was trying to run it on the raspberry ;) 

    I got it working now. Thanks a lot. 
Sign In or Register to comment.