JGAurora A5S Checksum error on Serial

Hi all,

This is the very first time I ask for help here, nevertheless I am going to try to be as specific as I can. I have the issue that I have connected my A5S printer to my OrangePI based Repetier server.
I can connect to the printer, the connection seems to be stable. I can control the printer, using the control view on the server side and so on.
However, when I come to the point to print with it, the printer starts printing but after ~5-10 secs it got halted. (Using 127 bytes input buffer on Serial) When I try to change the input buffer to 63, the only thing I got is additional 10secs, but after that it got halted again.
I have tried to debug it a bit, see the snapshot here
For me, it seems like the buffering on the Serial bus is incorrect, and after executing gcode, the checksums got shifted, so the calculation will be incorrect. I have tried to contact the JGAurora company itself, but they were not really helpful. I could not earn to talk to a competent guy, who could tell me how I should configure the Serial connection.

Does anybody had such an issue? Or is there anyone who has an idea how could I solve this particular issues?

Thanks a lot in advance for the valuable comments!
Have a nice weekend!


  • Does more look like Repetier-Host.
    Try in printer settings->printer disable sending ETA to printer display.
    Unfortunetly in your debug commands logging was disabled so I see not which command causes it, but on several versions M117 causes troubles so not sending M117 helps here and ETA to display uses that command.
  • Hi,

    It's a bit strange to me, since as I remember I have tried to disable once, but it seems to work now.
    Thanks a lot,
Sign In or Register to comment.