Verbindung Repetier Server mit Anycubic (Marlin) Drucker geht verloren

Hallo.
Ich bin ein Neuling in Sachen Repetier Server ab nicht im 3D Druck. Ich habe Octoprint bis vor kurzem verwendet, bin aber jetzt zu Repetier-Server gewechselt. Das heißt, ich möchte gern! Aber ich kriege es nicht hin, den Anycubic Chiron damit zuverlässig anzusteuern.
Die Einrichtung des Druckers funktioniert gut, die Einstellungen werden vorgenommen und der Druckvorgang beginnt. Aber irgendwann bleibt er im Druck stecken, kühlt Hotend und Bett ab und trennt sich vom RepetierServer. Wiederverbindung nicht möglich, aber das Startsignal vom Drucker ertönt kontinuierlich. Auf dem Web Interface ist die Verbindung als getrennt dargestellt und lässt sich auch nicht wiederherstellen, der Drucker scheint dies aber zu versuchen, hörbar an der Startmelodie.
Einstellungen zu RTS / DTR schon durchgespielt, da gibt es nur eine die überhaupt funktioniert. Baudrate steht in Marlin FW und Verbindungseinstellungen auf 250000, USB Kabel ist auch schon gewechselt, keine Verbesserung. Wann die Kommunikation abbricht lässt sich nicht reproduzieren....

Gibt es iregndwelche Lösungsansätze?? Habe das Forum schon durchkämmt aber leider nichts gefunden was zu meinem Problem passt, weil der Drucker ja eben erstmal ansteuerbar ist und auch den Druck beginnt...

Danke vorab!


Comments

  • Ein Hinweis noch, im Terminal ist ab und zu nach Eintritt des Fehlers was von "checksum-error" zu lesen, ob das damit in Verbindung steht weiß ich nicht

  • Zuerst mal den Grundtest ob du Unterspannung hast und vielleicht die idee die 5V Leitung abzuklemmen wie hier beschrieben:
    https://www.repetier-server.com/knowledgebase/undervoltage-and-throtteling-of-pi/

    Server versucht bei Trennung immer neu zu verbinden und wenn du die Melodie hörst scheint der Teil ja zu klappen. Frage ist warum klappt es am anfang und dann nicht mehr. Jetzt bleibt die USB verbindung ja dabei normal bestehen und ich vermute das damit etwas nach dem Fehler nicht mehr stimmt und linux nicht mehr Daten sendet wie es sollte. Was passiert wenn du den USB stecker abziehst und neu verbindest? Dann wird Linux ja usb neu initialisieren. 
    Wenn der Fehler beim Drucker usb konverter liegen würde müsstest du den Drucker zusätzlich ausschalten und usb Trennen (falls er wie der anycubic mega I3 per usb mit strom versorgt wird).


  • Wenn ich den Drucker vom USB trenne und wieder verbinde, geht das gleiche Spiel los. Versucht ständig neu zu verbinden. Erst das Ausschalten des Drucker beendet das alles.
  • Das mit den +5V abkleben probiere ich mal, hab erstmal ordentliche USB Kabel gekauft, die mitgelieferten überzeugen mich eh nicht...
Sign In or Register to comment.