Connection OK, but unable to send commands or receive informations

I just installed Repetier host on my ubuntu 14.04.
My printer in a BCN3D+
I succeed in connecting repetier with the printer : com port detected and when Iclick on "connection", I can see "connected : default" botom left of my screen.
But thats all : no information about the printer (temp for ex) and no possibility to send an order to the printer. The orders remains buffered and are not sent.
I tried several speeds for the connection...
With the same printer, I tried Repetier on the same computer but with Windows XP and it works well.
Thank you for your help and excuse me for my poor english ;-).


  • Do not use 250000 baud. Next release will have a trick to use it but current version does not support it on linux.
  • I've already tried this.
    But it doesn't work.
    I tried almost all speeds possible...
    But you're rigth with 250000 I get another error message....
    Any other idea ?
    Thank you.
  • Reset on connect setting can also have influence. Use the same as with windows where it works. Apart this I see no reason that it works with one os and not with the other.
  • I have the same problem. I run Ubuntu 14.04. It all worked when I was using Repetier Host 1.x.x but I upgraded to v1.5.6 and now Repetier says it is connected but no sensors are responding and no commands work. I am using a Bukobot duo 3D printer.  In Linux terminal the command dmesg | grep tty reports that I have a USBO port and a FTDI converter attached to it.  I tried every combination of USBO port and FTDI port with every baud rate, nothing changed.  Anyone?
  • What baudrate are you using? There is a new setbaudrate executable included in 1.5 that should work on more combinations. The old one only worked with ftdi drivers.
  • I had to lower my baud rate to 9600, I was then able to connect. Same problem though,  I cannot move the heads or receive any data. The commands get hung up in the buffers.
  • Make sure you are using exactly the baudrate from firmware. For linux use 115200 in firmware. For repetier-firmware make sure to change eeprom mode to force the new firmware! Then make sure to use the right port and it will work. You can connect even with wrong baud rate or port but communication will not work then.
  • I set the baud rate in the firmware to 115200, then uploaded to the printer. Connect with new baud rate and everything works. Thanks for the help.
  • What does log show? Enable all log options to see everything.
Sign In or Register to comment.