Printer connects but does not respond to commands

Hello, My first post! 

Could use the help.

So My printer is connecting to my computer through a hard line USB. When I press connect the printer turns off and resets like normal but when I go to send any other commands it just idles and has commands waiting. 

I have tried several coms and my printer only responds on com3

System Settings.

Any Cubic Delta style linear rail with heated bed

Please help.

Im having to level my bed manually its the worst :( 


  • Oh forgot to mention this happened after doing the new update. I reinstalled the old version to see if it was an issue with my printer communicating with the new program and it is still happening on old version 1.0.6
  • Is protocol on autodetect? What do you see in log (disable easy mode enable ack/commands). Might be dtr/rts settings preventing communication - they are reactivated in 2.1.6 and you need to install it back to be able to change these. Try all combinations and reconnect.
  • Ok so protocol is on auto detect. Im not exactly sure how to reinstall drt/rts settings. I hit the button on the top right to disable easy mode and nothing happens. I've uninstalled the newest version of rep out of spite and now using old faithful which is still not working. This is so frustrating every thing was working fine this new upgrade has totally ruined my work flow. 

    The only thing my printer will still respond to is pressing the connect button every thing else is dead. 

    Im about to just find another program and start over. 

    I've done so much searching and trouble shooting and nothing is working at all. 

    Ive tried every single different bauderate by applying and disconnecting and reconnecting. 

    Ive also updated the server program and went and directly connected through the server by opening server front end and connecting there. I am still getting the broken red chain symbol online. 

    Now with updating my connection through the front end controls I can not connect to the printer at all when server is on and connected. I have to stop local server and connect to printer then turn local server back on.

    Below is my command bar.

    09:09:32.034 : Plugin SlicerSlic3r.SlicerSlic3r:An item with the same key has already been added.
    09:09:32.035 : Plugin SlicerSlic3rPE.SlicerSlic3rPE:Could not load type 'RepetierHostExtender.geom.IModelMetadata' from assembly 'RepetierHostExtender, Version=, Culture=neutral, PublicKeyToken=null'.
    09:09:32.226 : OpenGL version:4.2.0 - Build
    09:09:32.226 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_INTEL_fragment_shader_ordering GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shader_image_load_store GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_compute_shader GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_shader_storage_buffer_object GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode 
    09:09:32.226 : OpenGL renderer:Intel(R) HD Graphics 4600
    09:09:32.226 : Using fast VBOs for rendering is possible
    09:09:37.973 : Access to the port 'COM3' is denied.
    09:11:00.013 : "C:\Program Files\Repetier-Host\plugins\RepetierServerConnector\RepetierServerStarter.exe" stop
    09:11:06.990 : No start signal detected - forcing start
    09:11:07.006 : N1 M110 *2
    09:11:07.006 : N2 M115 *4
    09:11:07.006 : N4 M114 *3
    09:11:07.006 : N5 M111 S6 *66
    09:11:07.014 : N6 T0 *28
    09:11:07.014 : N7 M20 *54
    09:11:07.015 : N8 M80 *51
    09:11:07.363 : jO6?f?Jh??J'a5O-?*?&??}M?6?
    09:11:09.551 : "C:\Program Files\Repetier-Host\plugins\RepetierServerConnector\RepetierServerStarter.exe" start
    09:11:50.082 : Communication timeout - reset send buffer block
    09:12:08.242 : ?-*?*??}M?6J(?}M?6?
    09:12:54.395 : Communication timeout - reset send buffer block
    09:12:54.399 : N21 G28 *0

    Im not sure what else to even do.
  • 09:11:07.363 : jO6?f?Jh??J'a5O-?*?&??}M?6?
    That is a sign of wrong baud rate also  Access to the port 'COM3' is denied. would mean someone els eis already connected to printer on COM3 probably server.
    Server auto connects and in host you would use server-connector instead of serial connector so it doe snot need to be disabled. Alternatively you can disable printer in server so it does not connect automatically.

    Make sure firmware in server is set correctly.

    RTS/DTR has only 4 combination to test high->low and low->high for each of them.
Sign In or Register to comment.