After uploading g-code "it rotates" and takes forever (not ready to print)

Hi there,

when I am uploading an about 1 MB big gcode file (which is generated from Repetierhost with Slic3r), the upload time is normal and then the little rotating "working" icon apears and stays - the CPU is about 50% used from Repetier-Server. I wait for about 5 minutes - nothing happens it is rotating and not going to be ready to print. The CPU stays loaded at about 50 %. When I delete the file the CPU usage goes down. I tried it with several g-code files but only realy small and uncomplicated files are working and let me start with the print.
My g-code files are all in good condition and all printable with the normal Repetier-Host without any problems.
My machine is a Intel DualCore with 1.8 GHz rating, Running Windows 8.1 with about 2 GB Ram - until now it was fast enough for everything I've done in 3D printing.

Any ideas?


  • Even on a Raspberry Pi a 1MB file is parsed in a few seconds so that feels wrong. I have send you a PM with a updated version to test with.
  • Hi,
    I tried the version you sent to me. Nothing changed - but I found a solution for that issue: the problems are special characters in the filename like German-Umlaute and SZ-Signs...
    After renaming the files everything is fine. It would be very kind to fix that bug in later versions...

  • Thanks for the feedback. Just tested what you said and on Linux and Mac it works perfectly. Only windows has a problem. It stores with right name so it not that it can not handle it. But windows is always special, so I will see that I can fix for the final release coming the next days.
  • The new update is out and should work also with german umlauts. Problem was that normal file open with 8 bit utf-8 does not work with windows. Windows has 16 bit utf I guess. Anyhow with special streaming operators it works.
  • Thank you, I will have a try...
  • I have the same problem with "rotating for almost forever" here running 86.2 Pro on an RasperryPI1, but not using any Umlaute or ß in the filenames. Are there any things i can check ? 
  • If you use our image disable x-server on startup. Login with ssh (using putty for example) and edit /home/pi/.bashrc and remove the xinit line near end of file and reboot.

    Xserver would start chrome using up much memory and pi 1 does not have so much (512MB I think) so it might be that it gets really slow by swapping memory to sd card when you upload. Also I would expect more memory usage after upload when it starts rendering the image.

    Also a full sd card could be a problem.
Sign In or Register to comment.