Problems with extcommands.xml under Windows8.1

Hello there,

Like discribed in the manual I created the extcommands.xml file and stored it in C:\ProgramData\Repetier-Server\database
After restarting the repetier server service the new commands appeared in the menu - ok until here. The problem is that no of my created commands are working an in the server.log it says the following:

2015-05-14 16:07:19: Connection started:RF1000
2015-05-14 16:07:19: Reset printer RF1000
2015-05-14 16:07:33: Opening websocket 2
2015-05-14 16:07:33: New session: 1ofOdfHG3@OFPaD@Z8xuYx*fZ@B8wH0E
2015-05-14 16:07:46: Starting external command c:Windowsnotepad.exe with 0 parameters.
2015-05-14 16:07:46: Handling action runExternalCommand caused error System exception

My extcommands.xml looks like:

       If you want to run external commands, enter them in this configuration with
       full path. You will see them in the main menu. Copy this file into the
       <storage>/database directory.

       Security consideration: The reason there is no online editor for this is simply
       security. The commands you enter here are executed with the privileges of the
       daemon running the server. If you would allow online configuration, a hacker could
       simply add any command he needs to hack your system.
        <name>Server herunterfahren</name>
        <execute>c:\Windows\System32\shutdown.exe /s /m \\localhost /t 3200</execute>
        <confirm>Server wirklich herunterfahren?</confirm>
        <name>Herunterfahren abbrechen</name>
        <execute>c:\Windows\System32\shutdown.exe /a</execute>


        G-code files can contain
        @execute cmd param1 param2
        commands. To prevent external users from executing unwanted or dangerous commands,
        only commands defined here are allowed to execute. More over, only the shortcuts
        defined here are to be used as cmd in @execute. Prevent parameter where ever possible.
    <execute name="curl" allowParams="true">c:\Windows\curl.exe</execute>


So it looks like the repetier server is ignoring the backslash's !??
It tried to run the server with the logged in user instead the system user but nothing changed.

So I am out of ideas to create a workarround :-)
Happy for new suggestions...


  • The baskslash part is simple. Feat each backslash you want use two and one will get send and the command gets called.

    More difficult could be to start programs with gui. The server runs as daemon and not with your user account, so it can not open any windows. That might prevent programs from functioning correctly.
  • Hi, I will have another try - thank you for this information.
    The service is running with my logged in user account (I changed it in the service preferences - like I posted in my first comment).
  • Everything works now for me - running my desired tasks and batchfiles works like a treat :-)
  • Now I see what you mean. Is my first windows service so I did not know I could change user there.
Sign In or Register to comment.