zip File import not working

Hello and good evening together.

If I try to import a zip it shows "importiere" for a couple of minutes. Then it shows a message but to fast to read it. After that nothing 
is happend.
Does somebody have an Idea?

Thanks for Help

Comments

  • Assuming it was at a legal position it is a problem in server/zip format. E.g. old thingiverse zips work, but newer do crash the algorithm. We have already fixed this for next update and hope your zip variant also works. It will still be a requirement to have one of the standard zip compression algorithms and not one of the patented newer versions some compressors can create.
  • Thanks for your Information. How can I create on Zip with the "old Version"? Im using a Mac Book Pro. I tried Keka with different Kompressortyps and the Kompression Feature from Mac OSX. But no one works.
  • The problem can even exist with supported compression types. It was a problem that happened when parsing the file and some condition was met. So guess you need to wait for the update then it should work with no problems.
  • Ok thank u very much for the Information. I guess I have to wait. I would like to Sort all my projects and downloaded files on the Repetier Server. Do u now when the update is coming ... ? greetings 
  • No, working hard on update and hope in april. You can already download linux version if you use 0.93.2 version in download link but it is not finished, so will get more. But I think I already compiled the zip improvement into it.
  • Well I will wait for the Update. Thx for ur Help. Is there a way to Copy the files with ftp to the Project?
  • No - never copy manually files! Server will not notice or it will miss missing conversions it does on import.
  • edited June 17
    Hallo zusammen

    ich greife dieses Thema nochmal auf... mit dem letzten Update hat der Zip Import einmal funktioniert. Jetzt sagt die Software beim Import "Ups ich habe die Verbindung verloren" und alle Drucker werden getrennt. Der Prusa verbindet sich wieder aber mein Kossel zeigt "nicht verbunden" und in der Konsole wird folgendes angezeigt ...

    Recv:22:26:55.284: Response while unconnected:ok
    Mesg:22:27:22.819: Dtr: false Rts: true
    Mesg:22:27:22.824: Dtr: false Rts: false
    Mesg:22:27:33.955: Dtr: true Rts: true (2)
    Mesg:22:27:33.956: Dtr: false Rts: false
    Mesg:22:27:45.184: Dtr: true Rts: true (2)
    Mesg:22:27:45.185: Dtr: false Rts: false
    Mesg:22:27:56.519: Dtr: true Rts: true (2)
    Mesg:22:27:56.519: Dtr: false Rts: false
    Mesg:22:28:07.956: Dtr: true Rts: true (2)
    Mesg:22:28:07.956: Dtr: false Rts: false
    Mesg:22:28:07.968: Dtr: true Rts: true

    Hat da jemand eine Idee?

    liebe Grüße Rene 
  • Das ist eine reset Schleife. Versuch malden Drucker zu deaktivieren und dann wieder aktivieren. Klappt oft wenn er sich nicht verbinden will.

    Ist das ein Zip aus dem Internet? Würde es gerne mal testen. Werd auch noch mal mit einem eigenen zip testen. Hört sich ja an als ob der server abgestürzt ist beim upload und dadurch die Drucker neu gestartet wurden.
  • edited June 18
    Hallo nochmals ,

    Die .zip Dateien sind meistens von Thingiverse.
    Wenige von Prusaprinters.
    Ich habe den Server nebst Raspi komplett durchgestartet. Danach konnte ich fast eine Stunde, Dateien importieren und sortieren. Projekte anlegen/löschen verschieben usw. Das funktionierte dann.
    Gibt es die Möglichkeit Bilder hierher hochzuladen ? Beim Import habe ich als Beschreibung viele Seltsame Zeichen und Hieroglyphen bevor der eigentliche Text beginnt.

    Gibt es da etwas was ich beachten sollte?

    liebe Grüße René
  • Nein Bilder kann man hier nicht hochladen. Dazu bitte dropbox oder einen der kostenlosen Bilderdienste nutzen.

    Von welchem Text redest du hier? Wenn der Text nicht im UTF-8 Format ist kann er komisch aussehen. Zumindest reine Textdateien. word etc sehen immer komisch aus.
  • edited June 22
    Hallo nochmal,

    Die importierte Beschreibung sieht wie folgt aus ....

                   .:                     :,                                          
    

    ,:::::::: ::` ::: ::: 


    .,,:::,,, ::.:, ... .. .:, .:. ..... .. .. .:, .. :: .::, .:,


    ,:: ::::::: ::, ::::::: `:::::::.,:: ::: ::: .:::::: ::::: :::::: .::::::


    ,:: :::::::: ::, :::::::: ::::::::.,:: ::: ::: :::,:::, ::::: ::::::, :::::::: ,:: ::: ::: ::, ::: :::::. :::.,:: ::,::::: ::: :::  ::, ::: ::: ,:: ::. ::: ::, :: :::.:: ::.,:: :::::: ::::::::: :: :::::: ::::::::: ,:: ::. ::: ::, :: :::.:: ::.,:: .::::: ::::::::: :: ::::::::::::::: ,:: ::. ::: ::, :: ::: ::: :::.,:: :::: ::: ,,, :: .:: :::.::. ,,, ,:: ::. ::: ::, :: ::: ::::::::.,:: :::: ::::::: :: ::::::: :::::::. ,:: ::. ::: ::, :: ::: :::::::,:: ::. ::::: :: :::::: :::::.


                                ::,  ,::                               ``             
                                ::::::::                                              
                                 ::::::                                               
                                  `,,`
    

    http://www.thingiverse.com/thing:2138813 Medicine cabinet drawers by OmoBeanz is licensed under the Creative Commons - Attribution license. http://creativecommons.org/licenses/by/3.0/

    Summary

    I wanted drawers that could fit in a medicine cabinet. You shouldn't require any supports due to the way it was designed. I did this with Hatchbox wood and then stained it. All normal settings but with 101% extrusion. 

    50mm speed 220 degrees 50 degrees bed

    https://www.amazon.com/gp/product/B01092XXD4


    Ich weis jetzt nicht welche der Dateien diesen Zeichen verursacht....

    Offtopic als Info

    Bei mir hat das Update auf 0.94.1 den Server komplett zerschossen.... Beim Drücken auf auf Update kam noch "UPS Verbindung verloren" und beim Neustart gab es keine Verbindung mehr ..  weder per WLAN noch per Kabel. Auf dem Display wurde angezeigt "127.0.0.0 no Response " mit einer weißen Seite angezeigt.Die Drucker wurden wohl initialisiert aber sonst passierte nichts mehr. Habe den Server neu aufgesetzt mit dem 0.94 er Image und das Update hat seltsamerweise erst nachdem Rückspielen des Backups geklappt .

    liebe Grüße Rene 

  • Der Datenmüll ist Teil der Datei im zip. Ascii grafik denke ich, sieht aber grausam auf wenn man keinen monospace font nutzt, weil die da nicht klappen. Ignorieren.

    Das für einen pi nutzt du? Das erste mal war von einem alten image mit armel? Im neuen image nutzen wir armhf als default, weil der die Befehle die ein armv7 nicht mehr kann nicht enthält. Auf einem echten pi war das aber eigentlich beim testen kein Problem.
  • edited June 23
    Ich habe das letzte Image 0.93 nur auf nem Raspberry Pi 4 mit 1 GB Ram genutzt. Ich habe aus dem System heraus dann das Update versucht. Seltsam ....
    Er zeigt mir nach dem Rückspielen des Backups nich alle Projekte an .. ist da was bekannt?
    per SSH eingeloggt sieht das so aus:

    pi@Repetier-Server:/var/lib/Repetier-Server $ cd projects

    pi@Repetier-Server:/var/lib/Repetier-Server/projects $ ls

     Anycubic_Kossel_Linear_Plus_-_triple_point_   Kindersachen.dir

    'Covid-19 Sachen.dir'                         'Küche und Haushalt.dir'

     Dekoartikel.dir                              'Tests und Benchmarks.dir'

     Druckerteile.dir                              Werkzeuge.dir

     Elektronikprojekte.dir

    pi@Repetier-Server:/var/lib/Repetier-Server/projects $ cd "Covid-19 Sachen"

    -bash: cd: Covid-19 Sachen: No such file or directory

    pi@Repetier-Server:/var/lib/Repetier-Server/projects $ cd "Covid-19 Sachen.dir"

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir $ ls

    Gesichtsmaskenhalter  Nackenhalter  Nasenklammer

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir $ ls

    Gesichtsmaskenhalter  Nackenhalter  Nasenklammer  test

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir $ cd Nasenklammer

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir/Nasenklammer $ ls

    files  info.xml

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir/Nasenklammer $ cd Files

    -bash: cd: Files: No such file or directory

    pi@Repetier-Server:/var/lib/Repetier-Server/projects/Covid-19 Sachen.dir/Nasenklammer $ 

    Ahh ich seh grade ich habe mich vertippt ....  Dateien sind aber unter Files alle vorhanden.... per WINSCP mal getestet 

    liebe Grüße 

  • Ok, ich sehe du stehst mit Dateinamen auf Kriegsfuß:-)

    Du must aufpassen dass du auch die versteckten Dateien .computed und .models im Hauptverzeichnis eines Projekts mit kopierst. Da sind die gerenderted Bilder und das umgewandelte STL drin.
    ls -a
    zeigt die alle Dateien inklusive der versteckten. Das ist übrigens auch der Unterschied zwischen Alle Dateien exportieren = die du hochgeladen hast, und Projekt exportieren wo dann auch die versteckten Dateien drin sind. Exportierte Projekte können daher viel schneller wieder importiert werden, da die Berechnung entfält.

    Jetzt weiß ich nicht wie du deine Backups gemacht hast und ob die versteckten dateien drin sind. Wenn du sie nicht mehr hast, Projektweise zippen und als zip aufspielen, dann werden die neu berechnet.
  • Ja ich vertippe mich gerne mal, grade mit der Konsole ;-)
    Also ich habe das Backup mit dem Server Monitor erstellt. Habe dann das saubere Image von der Hp per Etcher auf die SD Karte installiert und beim Zweiten Mal die SDkarte direkt an das Notebook angeschlossen und die Zip Ordner einzeln entpackt und an die Entsprechende Stelle auf der SD Karte, kopiert.

    Projektweise zippen habe ich grade versucht ... Leider importiert er wieder keinerlei .zip Dateien. Egal aus welcher Quelle. (Eigene/Thiniverse oder Prusaprinters)
  • Ok das wird merkwürdig. Hab es gerade versucht. Also zip backup gemacht.
    zip per scp nach /home/pi kopiert (projects.zip)
    Dann login per ssh
    sudo -i
    cd /var/lib/Repetier-Server
    unzip /home/pi/projects.zip
    service RepetierServer restart

    Danach waren alle alten Projekte von einem Rechner auf dem neuen.
    Nutzt du ein linux Notebook oder wie konntest du die Dateien sonst nach dem unzippen kopieren? Windows kann ja ext4 eigentlich nicht lesen. Ich vermute das bei diesem Vorgang die Versteckten Dateien vielleicht verloren gegangen sind. Oder ich sehe nicht was falsch lief bei dir. So wie ichs beschrieben habe klappt es.

    Dann hab ich noch ein paar neue Thingiverse ZIP hochgeladen auch ohne Probleme.

    Ich hab das mit der armhf version 0.94.1 alles gemacht.
    Wenn du das aktuelle image genutzt hast solltest du auch armhf haben.

    Kannst du mir einen Link zu einem zip geben der nicht klappt? Vielleicht gibts ja welche die Probleme machen und andere nicht. Gibt ja auch unterschiedliche Komprimierungsarten in zip. 

    Oder siehst du eine Abweichung zwischen dem was ich mache und dem was du machst?
  • Hallo sorry für die späte Rückmeldung.

    Das Backup habe ich mit dem Rep. Monitor erstellt. Aber ich habe jetzt mal einen komplett neuen Server erstellt.
    Sauberes Image von eurer Homepage. (0.94) neue Sd Karte genutzt. WLAN neu eingestellt und mal einen Drucker zum Testen angelegt. Meine Exportierten Projekte kann ich problemlos importieren. Dann habe ich das Update auf 0.94.1 per Weboberfläche angestoßen. Zweimal ist nix passiert. Beim dritten mal kommt auf dem Display sinngemäß "Opps ich habe die server Verging verloren". Dann Neustart auf die neue Version und kein zip Import möglich.
    Die Meldung "importiere" wird angezeigt aber nichts passiert. Wenn ich die Webseite neu lade ist es als wäre nichts gewesen.
    BTW. Ich nutze einen Mac mit "EXT für MAC" von Paragon.

  • Nachtrag zum obigen Post.....

    Ich denke ich habe den Fehler gefunden vielleicht kannst du das noch verifizieren. Der Import von zip Dateien scheitert, wenn ich es über den Safari Browser versuche. Neues oder altes Image spielt keine Rolle.
    Warum auch immer, habe ich mal den Firefox Browser genommen und sieht da ... es geht. Die gleiche Zip Datei. Gegenprobe mit den Safari ergibt wieder den Fehler. Mit Firefox geht es .... was wird beim upload genutzt? Java oder ähnliches ? Vlt. hat Apple da irgendwas geblockt ....
  • Safari kann durchaus sein, ist ja immer gerne mal anders. Hab es auf meinem aktuellen Safari Version 13.1.1 (15609.2.9.1.2) getestet auf einen Server am Mac, Pi 4 und nano pi. Haben alle eigentlich problemlos geklappt.

    Welche Safari Version hast du? 
    Spielt die zip größe eine Rolle?


    Wir sprechen doch von normal zip import und nicht vom import exportierter Projekte, richtig? Nicht das ich das falsche am testen bin.
Sign In or Register to comment.