Stop print and babystep

edited April 7 in Repetier-Server
Hi,

I'm using repetiert server on a Raspberry Pi 4 with a touchscreen. Works great so far. At this moment I'm using an Ender 3 and a Prusa Mini with the repetier server.
There are a few problems that I cannot explain.

1. If I stop printing via touchscreen while printing, the hotend, bed and Fans are still on the last values and didnt cool down or stop. Is this a normal behavior? I think for security reasons they should turn off when stopped!

2. If I changed babystep via the touchscreen the printer stops for a few seconds. Its very annoying on the Prusa Mini because the Mini Display didn't work corretly while printing via repetier server. On the Ender 3 I still can use the build in controls for babystep.

3. I always received an warning that the print did not fit on the print bed. This happend with files sliced with Prusa Slicer and Cura.

Thanks a lot

Comments

  • 1. You just said to stop print - server automatically runs a script you defined in printer configuration. See g-codes->Event dependent. There you can add commands to stop heaters, go to park position and whatever you like. It is empty by default causing the described behaviour.

    2. It depends on support from Firmware. Need to test babysteps with prusa mini. All the function doe sis send M290 Z<distance> and it is up to firmware to ignore or do anything.

    3. Cura files might be because of the end gcode. There is a
    G28 X0 Y0
    after that add a
    G90
    to activate absolute positioning.

    PrusaEngine is beacuse slicer makes a prime line at y = -3 and I bet you have defined you y min and bed min to be at y=0 so that line is outside of bed causing the warning.

    You can ignore it, but better is to adjust bed and reachable positions to include y -3 instead of 0.
  • Hi thanks for reply,

    1. Thanks sounds logical :-) I changed the stop gecode and its working fine now!

    2. Ok, so there is nothing I can do about it?

    3. In cura I did relative positioning with G91 in start and stop gcode. I changed it to absolut and its working without and error now for the Ender 3.
    In Prusa Slicer the start/endcode looks correct for the mini. So maybe its a configuration issue in repetier server. 
    What I noticed, the home position in rep-server shows X0 Y0 but I changed to the real home position (X176 Y24). And if I click the "home" button in RS all axes did home correct but if I click "home X" or "home Y" in RS the axes crashed to max position and did not stop.
    Maybe I did something wrong.

    https://www.dropbox.com/s/sqldpxk4fqyea6m/bed_settings.PNG?dl=0
    https://www.dropbox.com/s/x3hz58r1u6c1m9i/controls.PNG?dl=0
    https://www.dropbox.com/s/jlxqldybwx30ld7/mini_home_position.PNG?dl=0
  • In Druckerform Y vorne muss -3 und hinter 180 sein, also genau umgekehrt.
  • Hi,

    aus irgendwelchen Gründen, habe ich wieder das Problem mit print stop.
    Ich habe den End gcode vom Prusa Slicer beim repetier server eingetragen für den Prusa mini.
    Aber irgendwie macht er das nicht. Wenn ich am RS Stoppe, dann hält der Drucker an, aber die Düse und Bett bleiben an und ich kann auch keine neuen Druck starten, oder der Drucker irgendwie über RS steuern. Erst wenn der Prusa Mini neu gestartet wurde, geht eine Bedienung über RS wieder.
    Wie kann das sein?

    "Wenn ein Auftrag abgebrochen wurde"

    G1 E-1 F2100 ; retract
    {if layer_z < max_print_height}G1 Z{z_offset+min(layer_z+5, max_print_height)}{endif} F720 ; Move print head up
    G1 X178 Y180 F4200 ; park print head
    G4 ; wait
    M104 S0 ; turn off temperature
    M140 S0 ; turn off heatbed
    M107 ; turn off fan
    M221 S100 ; reset flow
    M84 ; disable motors

  • {if layer_z < max_print_height}G1 Z{z_offset+min(layer_z+5, max_print_height)}{endif} F720 ; Move print head up

    so was kannst du nicht schrieben im server. Das ist eine prusa interne Steuerung die der server nicht machen kann. Da es eh nur z hochbewegt kannst du es weglassen. Bewegst den Kopf ja eh noch zur Seite.

    G1 E-1 F2100 ; retract
    ist gefährlich. Da muss vorher ein
    G92 E0
    sonst kann dass auch -50cm bedeuten je nach E position und modus!

    Der Rest sollte aber gesendet werden und keine Probleme machen. Wird aber nur gesendet wenn du im server auf stop während des Drucks klickst. Hab es grad noch mal getested und es klappte.
  • edited May 9
    Wie gesagt, ich habe einfach den Endcode aus dem Slicer kopiert. :-)

    Also dann so?

    G92 E0
    G1 E-1 F2100 ; retract
    G1 X178 Y180 F4200 ; park print head
    G4 ; wait
    M104 S0 ; turn off temperature
    M140 S0 ; turn off heatbed
    M107 ; turn off fan
    M221 S100 ; reset flow
    M84 ; disable motors
  • Yes, that is perfect.
Sign In or Register to comment.