MK3s PID Tuning

edited March 21 in Repetier-Server
Hallo Leute,

Habe das Problem das ich keine PID Werte angezeigt bekomme nach dem Autotuning. Das Tuning an sich wird gestartet und auch erfolgreich beendet wie im Bild ersichtlich.
Meine Einstellungen bzgl. Kommunikation zum Drucker sollten eigentlich passen, habe die Repetier-Software nun schon 3 Monate am laufen und bin sehr zufrieden.

https://up.picr.de/38114901ev.png

Vielleicht kann mir ja jemand helfen ...

Grüsse

Comments

  • was sagt den M503 ? 

  • Setz mal an den M303 befehl ein U ans ende, dann kannst du es mit M500 im Anschluss direkt speichern und musst die Werte nicht abschreiben

  • 0:06:59.457: echo:Steps per unit:
    0:06:59.461: echo: M92 X100.00 Y100.00 Z400.00 E280.00
    0:06:59.465: echo:UStep resolution:
    0:06:59.465: echo: M350 X16 Y16 Z16 E32
    0:06:59.469: echo:Maximum feedrates - normal (mm/s):
    0:06:59.473: echo: M203 X200.00 Y200.00 Z12.00 E120.00
    0:06:59.477: echo:Maximum feedrates - stealth (mm/s):
    0:06:59.481: echo: M203 X100.00 Y100.00 Z12.00 E120.00
    0:06:59.481: echo:Maximum acceleration - normal (mm/s2):
    0:06:59.485: echo: M201 X1000 Y1000 Z200 E5000
    0:06:59.489: echo:Maximum acceleration - stealth (mm/s2):
    0:06:59.493: echo: M201 X960 Y960 Z200 E5000
    0:06:59.499: echo:Acceleration: S=acceleration, T=retract acceleration
    0:06:59.502: echo: M204 S1250.00 T1250.00
    0:06:59.515: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    0:06:59.522: echo: M205 S0.00 T0.00 B0.00 X10.00 Y10.00 Z0.40 E2.50
    0:06:59.523: echo:Home offset (mm):
    0:06:59.526: echo: M206 X0.00 Y0.00 Z0.00
    0:06:59.527: echo:PID settings:
    0:06:59.530: echo: M301 P19.56 I1.65 D57.79
    0:06:59.530: echo:PID heatbed settings:
    0:06:59.535: echo: M304 P116.84 I6.09 D560.18
    0:06:59.539: echo:Retract: S=Length (mm) F:Speed (mm/m) Z: ZLift (mm)
    0:06:59.543: echo: M207 S3.00 F2700.00 Z0.00
    0:06:59.547: echo:Recover: S=Extra length (mm) F:Speed (mm/m)
    0:06:59.552: echo: M208 S0.00 F480.00
    0:06:59.560: echo:Auto-Retract: S=0 to disable, 1 to interpret extrude-only moves as retracts or recoveries
    0:06:59.560: echo: M209 S0
    0:06:59.564: echo:Filament settings: Disabled
    0:06:59.564: ok
  • Das würde dann so aussehen:

    M117 PID-Hotend
    M106
    M303 C1 E0 S230 U
    M500

    richtig ?
  • Also mit dem U am Ende des Befehls M303 bekomme ich jetzt zumindest die K, P und I Werte angezeigt (Bestätigung muss aktiviert sein im Konsolenfenster).
    Der Befehl M500 zum Speichern im Anschluss funktioniert nicht. Vielleicht weis ja hier noch jemand irgendwas dazu. Zumindest bekomme ich jetzt die Reglerwerte angezeigt und kann sie von Hand eintippseln und speichern ..

    Danke Lexan für deine Info !
  • Wenn M500 nicht funktoniert ist es in der Firmware nicht freigegeben. 
    Dann kannst du das als M301 PxxIxxDxxx in den Startcode vom Slicer schreiben

  • Der server hat auch G-Code Ereignis "Sende bei Verbindungsaufbau" dann wird die Einstellung automatisch mit dem verbinden schon gesetzt. Denke das ist der Beste Punkt wenn du über den Server druckst.
  • edited March 22
    Also M500 funktioniert eigentlich schon. Meine Vorgehensweise vor Repetier (Pronterface) war 

    M303 E-0 S230 C10
    M301 Pxx.xx Ix.xx Dxx.xx
    M500

    Hiermit wurden die neu ermittelten Werte gespeichert (Auch nach Spannung Aus/Ein)

    Über Repetier-Server -> Schnellbefehle
    M117 PID-Hotend
    M106
    M303 C6 E0 S230 U
    M500 

    Kann ja nicht funktionieren weil der M301 Befehl mit den ermittelten Werten fehlt .....

    Ist jetzt nicht weiters schlimm, das PID macht man ja nicht vor jedem Druckvorgang. Cool wäre aber schon wenn die ermittelten Werte des PID an den M301 Befehl übergeben werden könnten und dann mit M500 abgespeichert werden.
  • Das müsste dann aber eine Firmware Option sein die das macht. Wir können ja nicht vorschreiben das jeder der M303 sendet das automatischa uch macht zudem wir ja nicht im server wissen was in M301 stehen müsste. Solche ausgaben sind für jede Firmware anders wie auch Befehle. Da muss leider immer noch einer mit Verstand ran:-)
Sign In or Register to comment.