Repetier Server unreachable on Raspberry Pi 4

Hi everyone :)

I'm planning to switch from Octoprint to Repetier server, I got a brand new Raspberry Pi 4 B for this, and I followed the installation guide to install Repetier server on a 16gb sd card.

So far so good, I wasn't able to access it as access point but I had it on a lan cable so I could access it from my browser :) I went through the settings and set the correct timezone, then set up the wifi connection and then it rebooted... and since then it's dead :/

I think I have formatted and re-flashed the sd card 5 or 6 times by now, it does not show up as an access point, and it's also unreachable through the browser or Putty. I also tried making the network file and put it directly on the SD card as described on the website, but sadly that is not working either.

I'm not too familiar with Raspberries so this is going beyond my knowledge, I do not have a screen to connect it to so I cannot confirm if it's starting at all... I hope someone can give me some guidance here :D


  • When you reflashed sd card did it boot then and then not again or is it completely dead since that first reboot? Normally a fresh sd card should at least work as in first boot if it is not defect. You can verify image after writing to see if it is correct.

    Also important - did you always use same power plug? Pi 4 has a problem here being not standard conformant with some usb-c power protocol which can lead to problems. Their official plug does not have the problem but if you use another it might be.

    Last thing to test - you can connect it via hdmi to your television and even use a usb keyboard if you like - just to see if something happens.
  • It's been dead since the first reboot, I will dig up another sd card today to see if a fresh card will help I just stopped trying yesterday cause I kinda was getting out of patience :P

    I am using the original power plug and I tried various power sockets as well but that sadly didn't make a difference either.

    I'm not sure if I have a micro hdmi to regular hdmi, but I will get one so I can hook it up, I imagine it will make a lot more sense if you can actually see what is going on... I'll post an update later today :)
  • Since reflashing does not help also it worked on first run a defect is more likely. Hopefully just the sd card as it is cheaper. If you have also an older pi you can also put the sd card into that one.

    Also please always shut down the pi manually before unplugging. It will work often to unplug but then you get a problem sometimes from unpower while writing emf spike .... Know many users where sd card did not work after a while and after new sd card it worked again. So protect is as good as you can.
  • So I tried a bunch of other things:

    Got a micro hdmi cable and plugged it into my monitor, I keep getting "no signal" I did some googling on that so I did force hdmi, tried both hdmi groups and used the hdmi boost as well but still no signal on both hdmi ports.

    I found a brand new 16gb sd card, so I flashed it on the card and started it with this but also nothing :/

    I do have to admit though, I was not aware of the unplugging issues so I unplugged it a good amount of times by now.. does that mean I can throw the full raspberry away? :/

    I do have some Raspberry's Pi Zero W which I'm running octoprint on right now, I can try one of those and see if it boots on there.
  • For testing if pi is still alive I'd use a regular raspbian. We have disabled most output. At startup I only see a blinking cursor, then a black screen and finally the touch screen surface. On regular image you see it booting. But even a black screen is not "no signal".

    Image also runs on pi zero, but you should disable chrome - it does not have much memory so you do not want that plus it takes a lot of cpu power. See here:
    on how to disable. Apart from that it should also just boot on pi zero. Have one running inside my Prusa MK3. Hopefully with wlan access point.

    Regarding question pi defect or not - if image works on pi zero and not on pi 4 it might in deed be defect. But make sure to use latest image - old images did not support pi 4, but since it worked once it must be good. Counter test with official image to see boot sequence on monitor is also a good test. You can compare with pi zero monitor output as well.
  • Thank you for the detailed answers :) I re-flashed one of the cards and inserted it in my pi zero, and it does show as access point but when I want to connect it tells me that the "12345678" is an incorrect password, so I might lower the security to see if that helps and disable chrome as well.. if it boots correctly on the pi zero then I will put it to the pi 4 and cross my fingers I didn't kill it :#
  • So I got a more positive update! I disabled the chrome functions and put the security to WPA, and loaded it on my pi zero, I was able to log in to the access point and I set up the wifi connection with our home router.

    It rebooted and I was able to approach it from my browser without issues. So I shut it down from the repetier panel, took out the SD card and put it into the pi 4, it shows up in the router connection list but cannot be approached... I noticed the power supply makes a weird buzzing sound when it's booting, so I grabbed my dad's phone charger which is 2 amps.

    I started it again and it popped up right away in the browser fully functional, I shut it down again and plugged the original adapter again and it didn't re-appear so I'm pretty sure at this point that I have a faulty power supply :/
  • Good that it is only the power supply. Also timing to become defect was quite bad and confusing. Or it is the problem with power control on USB-C which the Pi 4 in first revision has. Not sure exactly what it was but know that this made not all USB C power supplies compatible. Guess you find more on it on pi homepage.
  • So far so good, the shop where I bought it has shipped me a brand new power supply which should arrive tomorrow. It's running stable at the moment, I really like how it works and the webcam quality seems to be far better and smoother than in Octoprint :)

    I am having some minor "ripples" over the whole surface of the print, I had the same with octoprint once when the sd card became too full, is there any settings I could tweak to resolve that? Other than that I'm loving it!
  • Server just sends the data. Not sure which "ripples" you mean. There are many reasons to get things like ripples and they can also just depend on printer and speed or sliced result. What is important from server side is that you get no empty move buffer and no timeout during print as that would cause blobs that you can see. If you have ping-pong disabled you get the fastest communication speed as we can then send 2 or more commands at once. Timeouts only happen when there are communication errors. Here it is good if firmware sends "wait", supports busy protocol (allows to reduce timeout to 3 seconds) and if it also sends ok with line numbers we can detect missed ok on the fly. Any of these 3 points is a big gain in faster recovery in case of errors.
  • I will check these settings to make sure :) Since it's a raspberry pi 4 I'm pretty sure the communication and performance will be fine, the Pi zero's sometimes struggled to keep up with the commands especially in curved surfaces so when that happened the print quality went to hell cause it was stuttering all the time :D

    I'll also check all mechanical aspects of the printer to be sure, but I recognized the pattern from a Pi zero so I was just wondering ;) The new power supply came in already so I gonna connect it and hook up the 2nd printer and then everything will be fully functional

  • Stuttering in curves is in deed a problem normally if object is too fine sliced for communication speed. On a pi you can normally send around 300 commands per second if ping pong is disabled and buffer allows at least 2 lines in parallel.
Sign In or Register to comment.