Server on RPi 3 borked

I'm running RS on RPi 3 with a HDMI touchscreen for an MPCNC with a MKS gen l 1.0 with Marlin FW. I tried out the RS Pro demo with the touchscreen and after the demo period the Pi is F'ed. It will boot, run for a minute then freeze up. If I ssh into it and "sudo service RepetierServer stop" in time then it will not freeze up. Watching top when it starts doesn't look like the cpu is maxing out or ram. I tried editing the /boot/repetier-image-setup.txt file to disable chrome - RUN_CHROME=0 but still the Pi locks up. Runs no problem after stopping RS.

Comments

  • Do you always shut down pi before removing power? If not it might be a defect on the sd card. If you have a second card you could try installing image there as counter test. Question is what is defect - server executable or some data it reads during run. How much time do you have until it freezes? You say you can log in so it doe snot freeze directly which makes me assume that at least the regular startup is working.

    What you also can try is moving /var/lib/Repetier-Server when server is stopped so it reinitializes config again. This helps in case it is a config file that makes the problem.
  • I don't always shut it down before removing power, I know that's bad. It would run maybe 30 to 55 seconds before locking up.

    I did an apt upgrade after stopping RS, rebooted and that seems to have fixed it. Strange, something must have been corrupted that the upgrade fixed. Thank you!
  • Sd card corrupts are always a pain as they have the strangest side effects. But in the end you should recreate the image when an update helped. It just means the "bad" structure is now not used any more but new files can make them reappear somewhere in future.
  • edited March 1
    It's borked again but I think I know what is happening. I scaled my MPCNC up a bit and while I was manually moving the machine around by hand with it unplugged I saw that the power light on the pi was flickering. The motors were regen'ing and I think this may be corrupting the sd. I had power being fed to the pi from a buck converter tied into my main 12vdc power supply and this is somehow getting regen'd through the MKS, through the buck converter to the pi. I'm going to flash a new image and run the pi from a dedicated supply and see if that takes care of the problem.
  • Uuh yes, back emf is not good. If you have a board with stepper sockets - watterott has adapter sockets with diodes to prevent back emf. Guess with a CNC you also have bigger motors the so the problem it self is also bigger.
Sign In or Register to comment.