Lost Connection and slooooooow gcode upload.

For the first 2 weeks that I had Repetier Server, it worked waaay beyond my expectations.  It was a dream to  use.

Now... not so much. 

I have Repetier Server installed on a Raspberry Pi with a 7" Pi screen and genuine RP power supply, but I do most of my monitoring on the mac via Repetier-Server Monitor. 

It's now regularly and consistently showing "Lost connection" on my Mac screen and I can't access any of the printers until it comes back online again, only to drop out again a few moments later...  The printers continue to print if they're already printing, but it's giving me grief trying to upload gcode.

"Connection lost.  Oops! I lost my connection to the server.  Trying to reconnect."

Which is my second problem that didn't exist before.  It now takes AAAAAAGES to upload even a small gcode.  And sometimes it takes many attempts as I get the 'Lost Connection" screen again and again.

I only have S3D, Google Chrome and Fusion 360 operating in the background, as I did before when everything was operating as what I consider 'normal'.  I also haven't updated any software for months.

I've tried rebooting both the Mac and the Pi, restarted all the printers and nothing has changed.  It's still erratic and slow.   The network is fine as I can still use the wifi and the internet during these "lost connection" moments.

What could be causing this?


  • his means connection between browser and server.Most likely your pi uses wifi and that is being disconnected regularly and slow otherwise. If you can use ethernet cable instead of wifi and you have no problems. Otherwise check if region is set correctly and if your router maybe has changed the channel to one that works not as good as other channels due to overusage from other routers.
Sign In or Register to comment.