Extrude 100mm with the Printermenu and with Repetier is different

edited January 23 in Bug Reports
Hello,
i have a Problem to calibrate my Printers.
If i extrude 100mm with the Printermenu, the Printer extrude 100mm.
If i extrude 100mm with Repetier, the Printer extrude 94mm.

What i do so far:
I checked the E-Steps in Marlin (93)
I checked the E-Steps in Repetier (93)

I checked it also with 2 other Printers. It´s allways the same Problem.
What is wrong?




Comments

  • You shoulde check commands being send in console. I think both will send in sum 100mm (server might split it into 2 50mm moves).
    My guess is that the speed differs and if you extrude too fast with filament it can not heat up fast enough to make it through the nozzle so it will slip or loose steps during extrusion making a difference.Server shows extrusion rate in mm/s and has 2 speeds preset - one fast and one slow define din printer setup in server.
  • I sent in Repetier at speed 2. I think it's definitely not too quick. And with PLA at 205 °. It's hot enough. My friend has the same problem. Also on 2 printers.

  • edited January 24
    The biggest problem is that we have both a Palette 2. Under-extrusion (or the wrong amount of extruder in this case) is counterproductive for printing with Pallet 2. So far we just don't know where it comes from.
    The correct amounts are in the console
    Everything is still speculation so far, but there seems to be a problem. 
  • Hallo, ich habe ebenfalls einen Ender 3, zudem eine Palette 2 und nutze Repetier-Server für meine Drucker.
    Nachdem @aruba und ich uns über dieses Problem ausführlich unterhalten haben und er das Problem gepostet hat, dachte ich schreibe auch mal meine Erfahrungen bzw. Ergebnisse meiner Tests und ich muss sagen ich mehr als schockiert!!!  :s :s :s
    Ich habe mal Testweise 200,00mm fördern lassen und habe festgestellt, das ich über das Menü des Druckers auch tatsächlich 200,00mm erhalte, aber wenn ich dasselbe über die Oberfläche des Repetier-Servers mache, erhalte ich NUR 198,00mm...
    Wie kann das sein????
    2mm weniger hört sich zwar wahrscheinlich nicht dramatisch an, aber bei einem Druck mit der Palette, die Ihre Filamentlängen auf bspw. 146.1579000000001 (Original Wert aus einer Datei der Palette 2) berechnet, ist das absolut unzureichend und kann und wird definitiv zu keinem guten Ergebnis führen (können)!
  • Repetier said:
    You shoulde check commands being send in console. I think both will send in sum 100mm (server might split it into 2 50mm moves).
    My guess is that the speed differs and if you extrude too fast with filament it can not heat up fast enough to make it through the nozzle so it will slip or loose steps during extrusion making a difference.Server shows extrusion rate in mm/s and has 2 speeds preset - one fast and one slow define din printer setup in server.
    Sie haben glaube ich das beschriebene Problem von @aruba verstanden.
    Es geht nicht darum, das vorne an der Düse nicht genug Filament geschmolzen werden kann, sondern das wenn @aruba und/oder ich eine Markierung bei 200mm vorm Extruder machen und dann über die Oberfläche 200mm fördern wollen, bei mir tatsächlich nur 198mm und bei @aruba nur 191mm gefördert werden...
  • I understand that this would be a problem. But after all server just sends gcode for move to firmware, so real extrusion is always dependent on firmware. Sending 
    G92 E0
    G1 E100 F60

    would extruder 100mm (if allowed by firmware, there is normally a length limit if exceeded move gets ignored) at 1mm/s. All extruders have a limit speed after which they slip/loose steps. This depends on temperature, nozzle size, material and force extruder can push filament with. For calibration it is important to stay below that limit. 1-2 mm/s is normally no problem. But as I said check in console what gets send to firmware then you see if server sends wrong distance or if extrusion does not fit.

    One more thing to consider - if you use manual control in firmware the server might not know the E position since you did not tell server about it. Send G92 E0 after changing position so server and firmware are again in sync regarding position.
Sign In or Register to comment.