Connection issues with one of my printers

Howdy, I'm using repetier host since August when I bought my first printer, a geeetech prusa I3 pro w, and it gave me any kind of troubles, so I learned a tons of things about curaengine and slic3r, but now I took a new printer for improve my little fablab, an

Anycubic I3 Mega

but i tried in several ways to connect it on repetier, and nothing seems to work. I used every infos on the manual, like searching the right COM (I tried to change it manually with some help of other makers in a general forum and on FB) and I set the baudrate at 250000 but it didn't worked. I also tried other bauds but the messages are always the same:

access to port denied  or the COM does not exists

I tried also using repetier server but it's the first time that I try to use it, and without any experience of it I'm worried about use it because my connection is everything but strong.
I tried to put the printer into the list but I've failed because it seems the printer looks disconnected, or without energy.

I can take a screenshot of the settings to show you what i tried to do in that panel, if you need it.
I also tried to uninstall and re-installing repetier but nothing has changet. But if I put the cable of my Geeetech into the USB of the pc and I click on the connection icon, it recognizes it immediately, without problem.

What's wrong in this case? It's a bug or what?
I would be sorry using just cura, because I am comfortable with the interface of this software


  • I have no problems connecting to my iMega using 250000 baud, RTS/DTR low to high, Marlin as firmware (in server).
    The 2 errors are different sources.
    COM does not exist is just windows has no such port. Make sure you have the correct serial driver installed. Windows/mac do not support it out of the box.
    Acces to port denied would mean other software is using that port. If you used repetier-server you should know it tries to connect automatically when it sees the port. So check if the printer is still activated on that port and select disable printer to prevent autoconnect.

    With repetier server and some manipulation of the firmware the connection works.
Sign In or Register to comment.