localtime should be a symbolic link

Hello,

i found in the daemon.log and in the syslog allways this messages. what can I do to fix that?



Jan 15 13:51:11 RepetierServer systemd-timedated[29296]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:51:11 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:52:13 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:52:13 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:52:13 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'
Jan 15 13:52:13 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:52:13 RepetierServer systemd-timedated[29370]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:53:15 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:53:15 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:53:15 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'
Jan 15 13:53:15 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:53:15 RepetierServer systemd-timedated[29443]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:54:18 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:54:18 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:54:18 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'
Jan 15 13:54:18 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:54:18 RepetierServer systemd-timedated[29515]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:55:20 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:55:20 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:55:20 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'
Jan 15 13:55:20 RepetierServer systemd-timedated[29588]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:55:20 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:56:22 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:56:22 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:56:23 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'
Jan 15 13:56:23 RepetierServer systemd-timedated[29661]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
Jan 15 13:56:23 RepetierServer systemd[1]: Started Time & Date Service.
Jan 15 13:57:25 RepetierServer dbus[457]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
Jan 15 13:57:25 RepetierServer systemd[1]: Starting Time & Date Service...
Jan 15 13:57:25 RepetierServer dbus[457]: [system] Successfully activated service 'org.freedesktop.timedate1'


Comments

  • Quite a lot warnings. I checked on my image there it is a link. Guess it was created when I had set the timezone. On recent images you can go to Global Settings->WLAN->timezone and define a time zone. I guess that would set the link.

    On older images login on ssh terminal and run
    sudo raspi-config
    and go to setting time zone.
  • Hi,
    thanks for your response. I check it allready in the raspi config. There is the correct timezone set.
  • If I check it I get

    pi@Felix:~ $ ls -l /etc/localtime 

    lrwxrwxrwx 1 root root 33 Sep 14 12:00 /etc/localtime -> /usr/share/zoneinfo/Europe/Berlin

    marking it as link. What do you have? Or did message disappear?

  • edited January 17
    The messages are still there. The messages comes 1000 times in a row.
    Maybe it's not a problem either!!!??? I dont know.



    Jan 17 05:01:20 RepetierServer dbus[458]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
    Jan 17 05:01:20 RepetierServer systemd[1]: Starting Time & Date Service...
    Jan 17 05:01:20 RepetierServer dbus[458]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 17 05:01:20 RepetierServer systemd-timedated[25433]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
    Jan 17 05:01:20 RepetierServer systemd[1]: Started Time & Date Service.
    Jan 17 05:02:23 RepetierServer dbus[458]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
    Jan 17 05:02:23 RepetierServer systemd[1]: Starting Time & Date Service...
    Jan 17 05:02:23 RepetierServer dbus[458]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 17 05:02:23 RepetierServer systemd[1]: Started Time & Date Service.
    Jan 17 05:02:23 RepetierServer systemd-timedated[25871]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
    Jan 17 05:03:25 RepetierServer dbus[458]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
    Jan 17 05:03:25 RepetierServer systemd[1]: Starting Time & Date Service...
    Jan 17 05:03:25 RepetierServer dbus[458]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 17 05:03:25 RepetierServer systemd-timedated[26310]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
    Jan 17 05:03:25 RepetierServer systemd[1]: Started Time & Date Service.
    Jan 17 05:04:27 RepetierServer dbus[458]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service'
    Jan 17 05:04:27 RepetierServer systemd[1]: Starting Time & Date Service...
    Jan 17 05:04:28 RepetierServer dbus[458]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 17 05:04:28 RepetierServer systemd-timedated[26750]: /etc/localtime should be a symbolic link to a time zone data file in /usr/share/zoneinfo/.
    Jan 17 05:04:28 RepetierServer systemd[1]: Started Time & Date Service.

  • I checked my log and have it similar minus the warning. Did you check if /etc/localtime is a link or not as I asked last time? The messages are completely harmless it is just a message that timedate1 was called due to some event.
  • edited January 17
    Repetier said:
    Did you check if /etc/localtime is a link or not as I asked last time? 
    Sorry, i don't know what you mean. I don't know how i can check it.
    But when it's harmless, then is everything Ok for me. I thought, it would be a problem.

  • Just run
     ls -l /etc/localtime

    as mentioned in above post and see what it returns in ssh console. See my example above.
  • edited January 18

  • So file is there just not a link but a copy of the fie. Guess in that case it is ok to ignore the message. It will still take the right contents assuming they are in the file. The selection command just did copy the file instead of linking it.
Sign In or Register to comment.