CR10s pro v2 connected but no control

We just got the CR10s pro V2 and it says connected but temp say zero and we cannot control the printer.  If we change the comm port settings it either makes no difference or it disconnects.  This printer works perfect on Octoprint with the same connection settings.  Anything I can try?

Our CR10s we got early 2019 works great and we tried matching the settings.  We also verified we have the latest firmware.

This is the first printer out of 7 that we’ve had issues with.  2 have Repetier firmware, 3 have Marlin and the last two are the CR10s (Marlin?) firmware.


  • Make sure firmware is set to Marlin or it will not work especially if repetier-firmware is selected instead.
    If it still does not work check baud rate and try setting RTS/DTR to different values especially high/low and low/high. Some boards only communicate in either of these combinations.
  • I thought we selected Marlin but I’ll verify. I know we tried all RTS/DTR settings as per a different post about a similar issue.

    Thanks for the tips.  I know it has to be something simple since the older CR10s works.
  • Just to close this out, I thought both of the other printers were set to Marlin by default so I assumed this one was too.  It was not.  This fixed it.  Thanks!
Sign In or Register to comment.