0.93.1 + Raspberry pi + Waveshare 3.5 inch LCD screen saver is not disabling


I'm using 0.93.1 on Raspberry pi 3 with waveshare 3.5 inch LCD screen, everything works just fine but but i couldn't disable the screen saver. I'm setting timeout to 0 but it goes to sleep anyway, what am i missing here?


  • The screensaver is controlled over a script /usr/local/Repetier-Setup/bin/screensaver
    Actually it does this:

    case $CMD in
    # Add code to run on screensaver activation
    # Add code to run on screensaver deactivation
    export DISPLAY=:0
    if [[ "$P1" == "0" ]] ; then
    xset s off
    xset -dpms
    xset s noblank
    xset s reset
    echo "Screensaver disabled"
    xset s on
    xset +dpms
    xset s blank
    xset s $P2
    echo "Screensaver enabled"
    so it sets xserver flags to run it or not. If these flags do not work for your display, you need to modify the file with the required command. The server gui only controls the darkening of the screen. The full disable is handled by linux + xserver configured by the command. I had once a display where I needed to toggle a output pin to enabled/disable backlight whcih I added in on/off but never had the problem that the xserver did know how to enable it and does not disable. Maybe the docs for display say how to configure screensaver?
Sign In or Register to comment.