nach ändern der extcommands.html ...

... werden nicht nur meine neuen einträge nicht angezeigt, sondern es verschwinden auch vorhandene.

aber mal von anfang an:

ich möchte eine mit tasmota geflashte wlansteckdose gerne über das druckermenü ein/ausschalten.

dazu habe ich eine sonoff.sh erstellt, diese .sh habe ich in den ordner /home/pi/ gelegt und mit 0755 rechten ausgestattet.
soweit so gut.

nun passe ich die datei extcommands.xml mit sudo und nano meinen bedürfnissen an.
ich füge folgende einträge hinzu:

<command>
        <name>Power Supply ON</name>
        <execute>/home/pi/sonoff.sh on</execute>
    </command>
    <command>
        <name>Power Supply OFF</name>
        <execute>/home/pi/sonoff.sh off</execute>
        <confirm>Really switch off?</confirm>
    </command>

danach, so jedenfalls der plan, sollten 2 neue einträge im hauptmenü erscheinen.
ABER
nicht nur, dass diese einträge nicht erscheinen, nein, es verschwinden auch die standarteinträge shutdown und reboot server.
ich komme also gar nicht dazu, zu testen ob meine .sh datei funktioniert

was mache ich falsch?

danke fürs lesen
volker

Comments

  • Wenn alles weg ist, ist es vermutlich keine valide xml Datei mehr. Sieh mal in /var/lib/Repetier-Server/logs/server.log nach ob da was drin steht.

    Auch mal die extcommands.xml hier hochladen 

    https://www.xmlvalidation.com/?L=2

    und prüfen lassen.
    Der Teil den ich sehe sieht valide aus aber da fehlt ja auch noch einiges der Datei wo der Fehler sein könnte.
  • danke für den tipp. hatte wirklich an einer stelle ein > zuviel drin. jetzt klappt es.
  • dogson said:
    ... werden nicht nur meine neuen einträge nicht angezeigt, sondern es verschwinden auch vorhandene.

    aber mal von anfang an:

    ich möchte eine mit tasmota geflashte wlansteckdose gerne über das druckermenü ein/ausschalten.

    dazu habe ich eine sonoff.sh erstellt, diese .sh habe ich in den ordner /home/pi/ gelegt und mit 0755 rechten ausgestattet.
    soweit so gut.

    nun passe ich die datei extcommands.xml mit sudo und nano meinen bedürfnissen an.
    ich füge folgende einträge hinzu:

    <command>
            <name>Power Supply ON</name>
            <execute>/home/pi/sonoff.sh on</execute>
        </command>
        <command>
            <name>Power Supply OFF</name>
            <execute>/home/pi/sonoff.sh off</execute>
            <confirm>Really switch off?</confirm>
        </command>

    danach, so jedenfalls der plan, sollten 2 neue einträge im hauptmenü erscheinen.
    ABER
    nicht nur, dass diese einträge nicht erscheinen, nein, es verschwinden auch die standarteinträge shutdown und reboot server.
    ich komme also gar nicht dazu, zu testen ob meine .sh datei funktioniert

    was mache ich falsch?

    danke fürs lesen
    volker
    Hallo,
    könntest du mir dein Vorgehen bitte näher beschreiben? Ich bin gerade von Octoprint auf Repetier Server umgestiegen und möchte nun meine drei mit Tasmota geflashten Sonoff Basic über das jeweilige Drucker Menü und GCode steuern.
  • edited April 2
    ich habe das ganze (ohne den flashteil) nach dieser anleitung gemacht : https://reprap.org/forum/read.php?249,741441,743615 ; solltest du weitere fragen haben, melde dich nochmal



Sign In or Register to comment.