server 0.51.1 segfault on RPiB+ (armv6l)

I can't start repetier server 0.51.1 on my Pi B+, every start failed with a segmentation fault.
The Raspbian is up to date.

The strace :
execve("/usr/local/Repetier-Server/bin/RepetierServer", ["/usr/local/Repetier-Server/bin/R"..., "-c", "/usr/local/Repetier-Server/etc/R"...], [/* 18 vars */]) = 0
futex(0xbeda2c58, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, NULL, b6ec2000) = -1 EAGAIN (Resource temporarily unavailable)
rt_sigaction(SIGRTMIN, {0xb6eab20c, [], SA_SIGINFO|0x4000000}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0xb6eab0b4, [], SA_RESTART|SA_SIGINFO|0x4000000}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=8192*1024, rlim_max=RLIM_INFINITY}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

The XML :
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>


  • Just to be sure, are you using armel version. The hf will not work on the pi.

    There seems also a few things during startup that can cause a race condition with multithreaded stuff, so it sometimes does not start but on a second it will. This will be fixed in next release which is nearly finished.

  • Well, the hf works fine in 0.51.0, tried el version of 51.1 and it runs, thanks, I didn't notice the "Which version is the right" note on download page when I first downloaded the package.

    Thanks, problem solved.
Sign In or Register to comment.