Prusa i3 mk3 -- no temperature communication

We have three Prusa i3 mk3 printers connected to Repetier Server. One of the printers will not communicate the temperature to the server. We have tried connecting via different ports, updated to the latest firmware, but the temperatures of the nozzle and bed read 0oC and we can not start print jobs via the server.

The printer works fine printing offline.

Any suggestions for troubleshooting?

Comments

  • Does it communicate at all? If you go to console and disable all filters (including ack/M105) you should see reported temperatures in log. What format do they have? Do other commands work? If nothing works make sure the prusa is not set to use the internal RPi port instead of external usb port. Also ensure firmware is set to marlin with 115200 baud. 
  • hello,

    i work with @griffinhh, and i just did the following:
    1) deactivated the printer and waited a minute
    2) activated the printer
    3) waited to see a first response in the console
         (settings were Commands: On; ACK: On; Filter M105: Off)
    4) immediately sent an M117 command with the text "Gruess Dich!"

    as you can see below, it takes about a minute for the M117 to register / be logged.

    the printer settings are:
    Device/Port is listed as COM4, which is a USB port on my computer
    (Windows 10.7.17763, Repetier-Server Pro 0.92.1)
    how would i know if the prusa is set to use the internal RPi port or not?
    the firmware is set to Marlin, and the baud rate is 115200.

    begin log:

    11:15:21.234: N77 M105
    11:15:21.250: start
    11:15:21.250: N1 M110
    11:15:21.250: N2 M105
    11:15:21.250: N3 M115
    11:15:21.250: N4 M220 S100
    11:15:21.250: N5 M221 S100
    11:15:21.250: N6 G92 E0
    11:15:21.250: N7 G90
    11:15:21.250: N8 M82
    11:15:52.260: Warning: Communication timeout - resetting communication buffer.
    11:15:52.260: Connection status: Buffered:100, Manual Commands: 5, Job Commands: 0
    11:15:52.260: Buffer used:100 Enforced free byte:10 lines stored:8
    11:15:52.260: N9 G21
    11:15:52.260: @getip
    11:15:52.260: N10 M105
    11:15:52.260: M117 Gruess Dich!
    11:15:52.260: @getip
    11:15:52.276: M117 132.206.36.212:3344
    11:15:52.276: N11 M105
    11:15:52.276: M117 132.206.36.212:3344
    11:16:24.236: Warning: Communication timeout - resetting communication buffer.
    11:16:24.236: Connection status: Buffered:102, Manual Commands: 1, Job Commands: 0
    11:16:24.236: Buffer used:102 Enforced free byte:12 lines stored:6
    11:16:24.236: N12 M105
    11:16:24.236: N13 M105
    11:16:25.238: N14 M105
    11:16:26.238: N15 M105
    11:16:27.243: N16 M105
    11:16:28.243: N17 M105
    11:16:29.245: N18 M105
    11:16:30.245: N19 M105
    11:17:02.244: Warning: Communication timeout - resetting communication buffer.
    11:17:02.244: Connection status: Buffered:96, Manual Commands: 1, Job Commands: 0
    11:17:02.244: Buffer used:96 Enforced free byte:12 lines stored:8
    11:17:02.244: Warning: Too many timeouts without response - disabling timeout message!
    ...


  • That is strange. I see the "start" which is how firmwares identify start of operation when they recover from reset. So baud rate is correct. With ACK on we should get a "ok" for every command send, which you see does not happen. You can try all combination of DTR/RTS setting, but I do not remember that it was important with that board. But some boards work only in one combination as they use it for hardware flow control which is not used.

    Just to rule out a hardware problem with the board getting any data in printer direction, did you test with e.g. Repetier-Host if it can communicate? You need to deactivate the printer in server to do that. If that does also not work it might be a problem with hardware.

    I assume printer has main power on? The Rambo boards have the special problem that the port is visible even if there is no main power, but the firmware only runs when main power is on.

    If there is in deed a hardware problem there is a second serial port you can use to communicate. You would need to connect the pi GPIO header with a the header on the Rambo Einsy board. Actually you only need to connect GND, TX/RX for that I think. In prusa config you need set serial to RPi:On in that case. Please note that RX gets connected with TX and vice versa with normal naming scheme. A pi zero can be mounted directly on it so pin positions are 1:1 if orientation is correct.
  • I have the same problem on my prusa mk3, could you tell me what to do because I did not understand everything ?
    Do you find a solution ?




  • edited October 17
    In case I connect the RX / TX with my rpi3B +, is the GND mandatory ?? (because I use it already to feed a noctua fan)
    My rpi3B + is powered by an external source
    (In previous version Repetier or Firmware Prusa ? I confirm that the temperature worked with Repetier) it's quite strange.
  • That seems to be no communication problem. You just did not configure the printer in server to have a heated bed and extruder. That is why you just see no temperatures. So go to "Printer Settings and then to Extruders and add a bed and extruder.

    If you have no problem you can leave connection. Normally you need mass as well to get same potential if I understand it correctly. Otherwise what would be 3.3V? It is always against some reference = gnd that must be some on both. That is why all USB connectors also have mass.
  • Repetier said:
    That seems to be no communication problem. You just did not configure the printer in server to have a heated bed and extruder. That is why you just see no temperatures. So go to "Printer Settings and then to Extruders and add a bed and extruder.

    If you have no problem you can leave connection. Normally you need mass as well to get same potential if I understand it correctly. Otherwise what would be 3.3V? It is always against some reference = gnd that must be some on both. That is why all USB connectors also have mass.
    I'm really stupid I had not seen the tab for the extruder .... my apologies again thank you
Sign In or Register to comment.