connection problem between repetier and Cura 4.2.1

i am trying to connect these two, but always have connection problem, tried IP, server connection, neither worked. 


  • What are you connecting here? Host has no function to connect to cura 4.2.1 so you are doing something not supported.

  • Well, I have ultimaker 3, and i downloaded cura 4.2.1 on my laptop, and now i want to edit G-code and control the 3D printer instently with my g i dontloaded repterier host but it doesnt connect :( 
    i put in IP and port number, it tells me the target machine fails to respond.
  • If they have a 1:1 forwarding port it might work. The server can connect to a TCP port and communicate over this the same as with serial console. From their page I see these ports get used:
    • 5353: Discovery
    • 80: Printer control
    • 8080: Camera feed
    Not sure which would be used e.g. by cura or if they have a special ultimaker only solution. Would just try all 3 with your printers ip and see if one manages to connect. I guess 80 will be some web interface to control so I'd bet on 5353 also discovery might be anything.

    Where did you find port port 9066?
  • thanks, i got it connected, but it often disconnected itself. i dont know why

Sign In or Register to comment.