Firmware upload on Arduino 2 it doesn't work on Repetier Server V0.92.1 (SOLVED)

edited August 27 in Bug Reports
I read in the fixes of 0.92.1 that the problem of uploading firmware to Arduino 2 had been solved, but here on two Rasperry and two different printers the problem persists.
Try to upload but then only erase Arduino 2 but don't write the firmware.
There have always been problems uploading the firmware on Arduino 2 with the previous server versions, but insisting every he did sometime, now game over.
Now I've two "dead" printers without the firmware installed, please fix it!!!

Marco

Carico binari Firmware...
Ferma connessione stampante
/usr/local/Repetier-Server/modules/firmware/bin/bossac-arduino -p ttyACM0 -U false -e -w -v -b /var/lib/Repetier-Server/tmp/tmplua23.bin -R
Caricamento terminato
Riattivazione connessione stampante ...
Caricamento Firmware terminato.


Comments

  • With Putty i try to execute manually the operation, and this is the result:

    root@Raspberry1:/tmp# ./bossac-arduino -p ttyACM0 -U false -e -w -v -b firmware.bin -R
    Atmel SMART device 0x285e0a60 found
    Erase flash
    done in 0.041 seconds

    Write 248176 bytes to flash (970 pages)
    [                              ] 0% (9/970 pages)
    SAM-BA operation failed
    root@Raspberry1:/tmp#


  • edited August 27
    I've found the problem: the file "bossac-arduino" in the Repetier Server path directory it doesn't have the executable flag and this is the problem.
    After "chmod +x /usr/local/Repetier-Server/modules/firmware/bin/bossac-arduino" the firmware upload work fine, but it doesn't show the uploading progress.
    The default flag:

    -rw-r--r-- 1 root root   58596 Jul 14 11:18 bossac-arduino




  • Thanks. Added a chmod to setup script to ensure flag is set correctly.

    Reason you do not see progress is that the progress is send to stderr and not stdout. With the new changes only stdout is forwarded to gui so it misses the progress.
Sign In or Register to comment.