can't upgrade from 0.91.2 to 0.92.0

edited August 1 in Bug Reports
Hi! I can not upgrade my repetier-server.
sudo dpkg -i Repetier-Server-0.92.0-Linux.deb
(Reading database ... 51658 files and directories currently installed.)
Preparing to unpack Repetier-Server-0.92.0-Linux.deb ...
Uninstall Repetier-Server
Removed /etc/systemd/system/multi-user.target.wants/RepetierServer.service.
Unpacking repetier-server (0.92.0) over (0.91.2) ...
dpkg: error processing archive Repetier-Server-0.92.0-Linux.deb (--install):
 unable to make backup link of './usr/local/Repetier-Server/www/js/angular-i18n/angular-locale_ast-es.js' before installing new version: Operation not permitted
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Install Repetier-Server
You may see warnings about groups. These can be ignored.
The user `repetierserver' is already a member of `tty'.
The user `repetierserver' is already a member of `dialout'.
adduser: The group `intserial' does not exist.
adduser: The group `ugpio' does not exist.
The user `repetierserver' is already a member of `gpio'.
Created symlink /etc/systemd/system/multi-user.target.wants/RepetierServer.service → /lib/systemd/system/RepetierServer.service.
Processing triggers for systemd (232-25+deb9u11) ...
Errors were encountered while processing:
 Repetier-Server-0.92.0-Linux.deb

If i use web-face it not work too. I use the server in raspberry pi 3.


Comments

  • Looks like installer had a problem with one file. First I‘d retry and then delete the file manually and then retry. Could be a corrupted filesystem preventing file copy/delete in that case try a filesystem check to fix it.

    you should always use the shutdown function in server main menu before unpowering, also direct unpowering often works fine it van always vause problems.
Sign In or Register to comment.