print limit message too large : Limit x y z

edited July 30 in Repetier-Server
Bonjour,

Je test actuellement les 14 jours d'essai avant d'acheter une licence, à chaque fois que je lance une impression j'ai le message suivant :
"D'après les limites x y z de votre imprimante, cette impression est trop grande pour votre imprimante, imprimez-vous de toute facon ?"
J'ai pourtant correctement rentré les dimensions d'impressions de ma Prusa MK3 dans les réglages alors qu'est-ce qui ne va pas ?
Merci pour votre aide ce serveur est vraiment génial et je pense acheter bientôt ma licence pro :)

Comments

  • Set bed and y min limit to -3. PrusaSlicer creates a line at Y -3 which is outside if you tell your bed to start at y=0. That is the typical problem when this happens with prusa printers.
  • Je dois mettre -3 dans "Y-min" ?


  • Yes there and also in bed shape, both are important.
  • Unfortunately, this didn't solve the problem for me. I noticed this behavior since i have upgraded to 0.92.0. Becaused i changed nothing. In the repetier-server settings and in the slicer.
  • Did not notice this during testing, but might be because i ignore that line anyway in my gcode with @nosize and @size so previes look bigger. Need to test when i‘m back.
  • For me this to correct the problem thank you very much  :)
  • For your informartion. I made a test withe the prusaslic3r today. An i get no printer limit warning, with this gcode.
    Do you see something in my Cura-Startcode, that exceeds the limits?

    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 Z0 ;move X/Y to min endstops
    G0 Z0.15
    G92 E0 ;zero the extruded length
    G1 X40 E25 F500 ; Extrude 25mm of filament in a 4cm line.
    G92 E0 ;zero the extruded length again
    G1 E-1 F500 ; Retract a little
    G1 X80 F4000 ; Quickly wipe away from the filament line
    M117 ; Printing…
    G5


  • Not in that code. But do not forget to check defined bed dimension in server as well. You have to fit inside both or you get the message. It is no problem to print the file none the less. Warning just compares computed dimension. If you check 2d preview you see the dimensions of the print or at least what server thinks about it.
  • Hmmm... I checked the manual control settings and the bed size on the server. Everywhere is the correct size configured. I tried another slicer (s3d) and like the prusa slis3r, no limit warnings. I tried some tests tonight and it looks that the problem is in the endcode of cura. As you can see in the screenshot, the bed moved foreward in the end, to grab the print easier. Normaly, the printhead/bed should move to the top left corner, x0, y210 in my case, what he do. But it exceeds the limits on the server completely. Without an endcode, everything works fine. So i have to investigate in this direction.


  • I solved the problem with a "g90" in the endcode before the bed move foreward. I also checked the old models, where i uploaded to the repetier-server earlier. It looks, that the previous version ignored the "relative position" of the nozzle and the new version notice the move outside the printbed. 

    Thanks for all your feedback!
Sign In or Register to comment.