Tool change using Repetier for a CNC machine

my machine did what it should have (it rose on the z axis waiting for the tool change) and repetier paused. But it never gave me an option to restart the “print” job after the bit was changed. Any ideas what to do?

thanks!

Comments

  • How did you do it? Normally you should have a @pause command to pause and then in host you just hit the continue button in top toolbar or if you print via server in server tab.
  • I did the cam in Estlcam and saved the gcode. The code reads at the time of tool change
    G00  Z5.0000 F480

    ;No.  3:  body
    M05
    M00
    ;Change tool: End Mill 1/8
    M03
    G00 X-1.1288 Y134.1230 Z5.0000 F2100

    should there be a “pause” written in there so that Repetier actually pauses and gives me the option to restart?
    What is the code for “pause” and where should I write it in?

    thanks!

  • I researched on the website here and tried writing @pause in numerous ways but none of them seemed to work, I must missing something.
  • M00 does not exist in our firmware. Replace them by
    @pause Change tool

    Make sure to send the gcode with our repetier-server or host as only these understand the @pause command.
    I'm wondering why it does pause without it. Or aren't you using our firmware in combination? In that case M0 might work but is firmware dependent so you must continue at the printer lcd I guess, but depends on firmware.
  • I’m using an MPCNC with Marlin firmware. Estlcam seems to add the extra 0 in their code I don’t know why, but M00 works like M0. I’m not using an LCD, I’m controlling the CNC with Repetier-host. I’ve done some cutting of simple 2d designs using one size bit and everything runs fine through Repetier. But if I want to do more complicated carves I need the ability to pause the program and change to a different bit. I just tried programming the @pause as you’ve suggested and it is still not pausing Repetier.
  • regarding M0 see :

    The Marlin Firmware does wait for user to press a button on the LCD, or a specific time. "M0 P2000" waits 2000 milliseconds, "M0 S2" waits 2 seconds.

    that explains why it stops at M0 respectively M00.  As Firmware is waiting for a button press it "pauses" but cannot continue.

    As your CNC doesn´t use Repetier Firmware i guess it cannot handle the @pause ; but not complete shure about that

  • Thanks for jumping in the conversation RAyWB. I wonder how I can resolve this. I even tried sending the Marlin restart code through the manual control window in Repetier and that did nothing. Do I need to add an LCD screen to restart?
  • edited June 30
    sorry, i can´t help out for marlin FW as i never used that stuff.
    (I´m repetier user from the bone ;-) )
    isn´t there a marlin forum ?

    btw ...  wouldn´t be a simple way just to split the gcode into several files ? (1 file for each bit)
  • I suppose I could split the files up, it just seems the ability to pause would be easier and more logical. I have the same discussion going on in the MPCNC forums maybe I’ll see about what Marlin has to say.

    again thank you for the suggestions
  • You misread my answer. You have to REPLACE the M00 with @pause. Otherwise you hang at M00 never coming to @pause. @pause is working on any firmware as it is solved firmware side.
  • I understood your answer. When I replace M00 with @pause, Repetier-host does not pause. It continues running the file as if there wasn’t any “stop” programmed at all. When I edit the code I am doing it within the edit gcode window in Repetier.
  • How do you run the files? As I said you must run from host not from sd card. From sd card host commands are ignored.
  • I’m running from Repetier-host on a PC. I appreciate your responses and efforts to resolve this, as I’ve said I’m new to this world, and the more I have thought about this I’m beginning to realize that maybe the “pause” function is not the best way to do a tool change and I need to explore some of the other avenues to achieve what I’m looking to do.

    again thank you for your time and efforts but I’m going to abandon trying to make “pause” work
Sign In or Register to comment.