Out of Video Memory / Exception While Drawing?

I am getting this message over where the "object" is placed. I have no visual just a pink screen.

Is this Repetier set up or is my computer not up to par with the proper memory.

It worked fine with the last Repetier Version...except I could not rotate objects.


  • What does the log say why it activated the warning? It's new that the host disables visualization on error messages and the only valid reason should be not sufficient video memory. That is when I see it.
  • It happens when I Start up Repetier without doing anything.
  • edited September 2014
    Would this be due to having a 32bit rather than 64bit?
  • No 32 bit should not be the problem. But on startup is quite unexpected, so I still would like to know the message in log (easy mode off, toggle log) to be able to narrow the problem.
  • "Error drawing 3d view:Attempted to read or write protected memory. This is often an indication that other memory is corrupt. / at OpenTK.Graphics.OpenGL.GL.DrawElemtns(Begin"

    at RepetierHostEctender.geom.Submesh.Draw....(and four more lines of this stuff)

    Memory Corrupt? What does that mean. I run AutoCad and other things and my Computer seems to be running at top notch.
  • So I used a friends 64 bit computer and downloaded Repetier. The 3D graphic on the right came up fine. I think this current version of Repetier does NOT support 32 bit computers and may be my issue.
  • Nope I'm wrong. I got my computer upgraded to 64 bit...no change. However found in my computer settings that my video card is not up to date.
  • So does it now work with updated graphic driver? What card vendor do you have?
  • Same at my computer
    system Win XP 32 bits
    Intel core 2 duo
    3 GB
    graphics card intel GM45
    any ideas what to do?
  • Looks like it is always a intel graphic card that makes problems.
    I think many intel cards have very limited graphic memory, so they run quite fast out of memory. Easy test is use a small object and test if it works. If it does and bigger don't it's a graphic memory limit you hit. Filament visualization can use quite a lot of graphic memory. Medium quality already needs around 128 bytes per point. Reducing to simple ( I know ugly) reduces to  20 bytes per point. Alternatively you can disable filament visualization in the status bar, and no memory will be used at all.
  • Hello.  I recently started using version 1.0.6 with the current version of slicer and now I'm getting the out of video memory message also, and have no visualization preview after slicing.  I tried setting preferences with Filament vis to Simple, travel moves turned off, and tried using only one light also (not sure if that would help any or not).  When I was still using version 90C and 95F I would get a preview of the sliced model and travel just fine, even with complicated models.  With version 1.0.6 even a simple cube gives me the Out of video memory message.

    System is a laptop running Vista (32bit) and my device manager shows the display adapter as:
    Mobile Intel(R) 4 Series Express Chipset Family

  • Hello,

    I am trying to connect Creator clone (wooden) 3D Printer.

    Like others, I get the Memory Error too.

    "Out of Video Memory / Exception While Drawing?"

    I am running W7 64 bits.  Computer says Intel Q33 Express  is my video chip?

    Does this mean I have to buy a video board?  I had it search for new drivers, but it likes what it has.

    Thanks for any info


  • OK, as I saw on another post, I changed the Color Setting on the Video to 16 Bit, now I can see the Build Object and
    don't get the error.
    So I had the same problem as others, this seems to solve it.

  • Are there any other options? I've updated my display drivers and lowered the display to 16 bit but I still get this error as soon as Repetier loads.
  • I have an nvidia 6200 with open GL. I have all current drivers and the error does not occur in Nvidia 5200 cards, the card sends an memory exception error and forces repetier host to fail.
     It seems to happen randomly so I expect repetier is trying to send info to either protected memory or it's generating a bad memory pointer. I've included the repetier  beginning log since there  is noting at the end which helps since the error is generated by nvidia. Note: Repetier, OpenSCAD, and FreeCad, all generate this error but Repetier Host Fails most offten, I suspect it's because it does the most writing to memory. especially when writing to the screen log.

    "< 13:17:08.637 : OpenGL version:2.1.2
    < 13:17:08.637 : OpenGL extensions:GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_get_program_binary GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_robustness GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_import_sync_object GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_alpha_test GL_NV_blend_minmax GL_NV_blend_square GL_NV_complex_primitives GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_ES1_1_compatibility GL_NV_fbo_color_attachments GL_NV_fence GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragdepth GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_lod_clamp GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render GL_OES_compressed_paletted_texture GL_OES_depth24 GL_OES_depth32 GL_OES_depth_texture GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_point_size_array GL_OES_point_sprite GL_OES_rgb8_rgba8 GL_OES_read_format GL_OES_standard_derivatives GL_OES_texture_3D GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object GL_OES_vertex_half_float GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum GL_WIN_swap_hint WGL_EXT_swap_control 
    < 13:17:08.637 : OpenGL renderer:GeForce 6200/AGP/SSE2/3DNOW!
    < 13:17:08.637 : Using fast VBOs for rendering is possible
    > 13:23:27.262 : ok
    > 13:23:27.262 : echo:Unknown command: ""
    > 13:23:27.278 : ok"
  • On my System the same:

    Win7 64Bit

    Repetier Host 1.0.6 from 08/2014 is working fine.
    Repetier Host 1.0.6 From 04/2015 Out of Memory - no 3D View since Start without any Model.

Sign In or Register to comment.