Second extruder doesn't heat

I have a 3D printer with 2 extruders the first works, but i tried to print with de second and repetier still doing the slicing with the first extruder and if a tried to print with both extruders the slicing it's ok, but when I start printing the bed is heating, the first extruder is heating and the second extruder doesn't heat and start work without heating



Comments

  • edited May 30
    And I tried to modify the start G-Code because the second extruder wasn't there, but it doesn't work and now the bed has a little movement when start heat but after a 30 seconds it returns at home and works normaly

    Here is the G-code modify by me:
    ; Default start code
    G28 ; Home extruder
    G1 Z15 F{Z_TRAVEL_SPEED}
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    {IF_BED}M190 S{BED}
    ; Activate all used extruder
    {IF_EXT0}M104 T0 S{TEMP0}
    {IF_EXT1}M104 T1 S{TEMP1}
    G92 E0 ; Reset extruder position
    G92 E1 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    {IF_EXT0}M109 T0 S{TEMP0}
    ; Wait for all used extruders to reach temperature
    {IF_EXT1}M109 T1 S{TEMP1}

    In bold is the code that I modify
  • Looks like you are using CuraEngine. There you must use extruders starting with first one. Use Slic3r or Slic3rPE if you want to use only a different extruder or write temperature without T0/T1 and select extruder before printing.Not sure what you want to say with the bed comment. Since you wait for temperatures communication is blocked until all heaters are hot then motions etc should work as expected.
Sign In or Register to comment.