Server on rasp Pi Z axis control not stopping

I recently installed Repetier Server on a Raspberry Pi (0.91.2 v14) and it seems the control for the z axis (and perhaps others) does not work correctly.   When I click on the down arrow (say from home position), it doesn't just move down the increment selected (1mm, 10mm, etc), it continuously moves down.   I have tried from both the server interface and from Repetier Host.   I do not believe this was the case when the server for the same printer was running from the PC (Server 0.90.1).  

I had copied printer the configuration from the PC to the Pi by exporting the config to an XML file and then only changing the connection port to match the Pi configuration.  The rest should be the same though the server versions are different so there are some additional settings available.  Nothing to suggest the problem though.  

I assume this is not normal behavior.  Is there a setting I missed?


  • That normally only happens if the Z server thinks you are at is not the same the firmware thinks. Go to console and send M114 to query firmware what it thinks Z is and see on right in move tab what server has for z position. normally it is the homing coordinate that is set wrong e.g 0 if you home Z max or vice versa.

    In console you also see the commands send and can say if the movement makes sense compared to command.
  • FWIW, I'm running on a delta (using Repetier firmware).  So home should be Zmax.  When I home (via buttons on server panel) it does in fact go up to home at Zmax.   LCD reports Zmax as well.    However Server Control Panel shows Z at 0 (like what is shown below, clipped from docs since I am away from printer).  

    The Z-Home Printer setting shows 0 as well.  Should this be manually set to match the ZMax value?   

  • Yes, what you have i settings is what server assumes is your position after homing. So if you have 0 and are at zmax going down 10 mm means -10 for server with that value. Will be clipped to 0 so it will go down to z=0. Setting this to zmax reported with M114 after homing would fix your problem,
Sign In or Register to comment.