Lan & usb not detected in server latest image

Hi,
I have installed repetier server image 0.91.2 on raspberry pi, I am trying to connect LAN cable to raspberry pi but it is not showing the ip address even if i want to import files from usb(pen drives) i am not unable to import it. Suggest the suitable best solution for the same, thanks in advance.

Comments

  • edited March 24
    Why so many bugs with latest version, first font and now this.. I am facing this issue too!! @RepetierSupport we can’t be facing these issues when we deploy the software as your OEM partner.. and buying bulk licenses
  • Do you have a DHCP server for lan? Linux fetches Ip automatically from DHCP server. If you have try rebooting while being connected. Also I can add and remove it and get a connection it might help to see it at start directly. Do the lights on lan connector turn on signalling connection (to rule out hardware defects) on router and pi?

    @sapsan The only thing we can control and know about is our server. These issues you talk about are in parts of the linux image. Ok we delivered it with a plugin that years later started to not work and cause problems. But how can we know such a thing? LAN connection is controlled by linux. There is currently not even an option to configure it (also we plan this for a coming release to help here as well). But again is must be our fault that suddenly linux dhcp client is not working? We test on our machine and if it works we publish an image. You test on your machine with your printer and will only offer it when it works there. So we both did not have these problems and had to assume all is fine. Such systems are so complex nowadays with dependencies on clients internet system, routers, ... that it is not possible to control all aspects. All we can do is test and fix what we see and learn and improve as we learn about special problems that maybe just 0,1% will have. Also often the server or even the linux system is not the real problem. Have had many problem reports and often there was an external reason for problems. Just as I said networks from user to printer has many hops and at every point an error can prevent wanted results.
  • No, I am directly connecting LAN from pc to raspberry pi, So it is not showing the IP address & I am not able to import files through USB.
    When I installed the older image version & auto-update it everything works fine, the LAN & importing files issue came when I installed fresh 0.91.2 image.
     what can we do?

  • I wonder that it worked with old version. We always left eth0 handling to default of the raspbian installation since it had dhcp client activated. Direct pc connection is not the supposed way to connect it since pc has no dhcp. Connect it to the router the pc is connected to and it will most likely work. Probably the next release will get eth0 configuration possibilities to assign it a static ip so you can set it manually and do same to pc. But for now dhcp server is a requirement.
  • Ok, I will connect it using DHCP.
    What about importing files through USB? What should I do?

  • Usb stick should be auto mounted if you insert the stick. Use the import wizard to copy it.
  • Case1:
    1)installing older image & auto-updating it everything works fine even i can import files through import wizard on LCD.

    Case2:
    1)installing latest version 0.91.2, but unable to import files because it is showing blank page inside import wizard on LCD.

    Even i have checked mount & unmount scripts.

    Is there any point am i missing something ?
  • I have to test. Newer linux updates have chaneg udev to run mount in sandbox mode so you can not access it. Had fixed this but maybe a update removed my setting.

    /lib/systemd/system/udev.service must look like this

    #  This file is part of systemd.

    #

    #  systemd is free software; you can redistribute it and/or modify it

    #  under the terms of the GNU Lesser General Public License as published by

    #  the Free Software Foundation; either version 2.1 of the License, or

    #  (at your option) any later version.


    [Unit]

    Description=udev Kernel Device Manager

    Documentation=man:systemd-udevd.service(8) man:udev(7)

    DefaultDependencies=no

    Wants=systemd-udevd-control.socket systemd-udevd-kernel.socket

    After=systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-sysusers.service

    Before=sysinit.target

    ConditionPathIsReadWrite=/sys


    [Service]

    Type=notify

    OOMScoreAdjust=-1000

    Sockets=systemd-udevd-control.socket systemd-udevd-kernel.socket

    Restart=always

    RestartSec=0

    ExecStart=/lib/systemd/systemd-udevd

    KillMode=mixed

    WatchdogSec=3min

    TasksMax=infinity

    MountFlags=slave

    MemoryDenyWriteExecute=yes

    RestrictRealtime=yes

    RestrictAddressFamilies=AF_UNIX AF_NETLINK AF_INET AF_INET6


    MountFlags must be shared ! Then mounting will work after reboot
  • Changing mount flags slave to shared didn't worked.
  • I think you did not run

    sudo systemctl daemon-reload

    after changing the file. After I did that it worked again.
  • after changing the file I run "sudo systemctl daemon-reload"  still not working.
  • That is what I did and it worked. So can't say what is wrong here, but will soon make new image with next update including the lan setup as well, so maybe best is to use that image then (V15) when released.
Sign In or Register to comment.