Repetier server raspberry pi image V14 won't boot after sudo apt upgrade


I am new to raspberry pi and linux. I recently bought the latest raspberry pi 3B+ and installed the repetier server image V14 on it using a windows system on a 8GB sd card. Then I followed the below procedure:


  1. Connect the raspberry pi internet via Ethernet and boot it up this SD card via SSH ----- It booted.

  2. Expand file system using raspi-config ----- ok.

  3. Reboot the pi. ------ ok

  4. From my computer (which is connected to the same LAN) and access http://192.168.x.xx:3344 ------- Ok, the reteptier front end shows up with the start trail page.

  5. I don’t activate the trail or do anything in the front end. I then return to the pi via SSH and perform sudo apt update ------ it takes about 15 minutes and is done.

  6. I then perform sudo apt upgrade ------ it says there are 24 packages to upgrade and takes about 6 hours.

  7. I then try to reboot it and the raspberry pi doesnt not boot (the act light doesn’t come on).


I remove the SD card, erase it and start with a fresh install of the repetier server image V14 and repeat the process. I get the same result at step 7.  

Do you have any idea why this happens?  Am I not supposed to upgrade the V14 image?

 Thank you very much for you time.



  • Upgrading is what I do before I publish a new image, so no reason not to do. What often breaks is the the gui does not come after an update. In that case login with ssh and run
    sudo raspi-config
    and set boot option to command line with autologin.

    Since we hide console it might look like a black screen but it has booted so you can login with ssh.

    Also maybe you used shutdown instead of reboot. Shutdown will only start pi after you remove power and connect it back again.
  • I had the same issue, was also noticing that the touch UI only would come up after ssh to the machine. So I set it to commandline with autologin and it worked since then...

Sign In or Register to comment.