Touchscreen UI acting weird

edited March 16 in Bug Reports
Hi,

So for no reason that i know of since about yesterday the UI of the touchscreen has changed. All the icons for the different functions etc have been changed for letters weirdly....no idea why...

Repetier Server Version 0.91.2


Comments

  • Yes, it is a strange thing. Please see

    https://forum.repetier.com/discussion/6329/repserver-0-91-2-shows-strange-symbols-after-upgrading#latest

    where we try to find the reason. Would be great if you could also post your findings and used versions of linux/chromium. 
    This seems to happen to different versions suddenly and til know we have not detected the common part causing the error. I hope with more feedback we find what caused the problem reading or showing the font responsible for it.

    Maybe the vanished preview image is caused by the same problem. I see that it is still working for me but others now get the same problem so clearly something is interrupting the process.
  • edited March 16
    Well its strange because i am on 0.91.2 since it came out and i noticed that this issue popped up maybe 2-3 days ago. Before that it was fine. I run a dedicated RPI 3 just for my 3D printer and it dosen't run anything else. I have not touched any underlying settings or anything in the system either so don't think any sort of update could be the cause. I have not run any updates to the system or anything

    I usually shut down the machine when i am done via a TP-LINK smart plug so no safe shutdown for me.

    Version of Chromium on my RPI: Chromium 51.0.2704.91 Built on Ubuntu 14.04, running on Raspbian 8.0

    I also checked the GUI via http://serverio:3344/modules/front2/app/app.html/ and there all the icons show correctly.


  • Ok, so far all users with the problem seem to be running on an older image with Raspbian 8.0. Looks like there is a connection.

    I have a report that 
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get dist-upgrade 
    sudo apt-get update
    sudo apt-get upgrade

    and reboot worked for a user. So that seems to update a critical element. Also he still has a problem not seeing all gcode images.

    If gui does not start any more run
    sudo raspi-config
    and set boot options to console with autologin.

    PS: You might want to make a backup of /var/lib/Repetier-Server. It contains all settings and data. You can then also use the backup to upgrade the image to V14.

  • edited March 17
    Hi,

    I did the steps as suggested and after reboot the GUI was still the same. Same incorrect icons etc.

    So i thought even though the gui did start i'd give the last option you suggested a try so i went into raspi-config and changed the boot option to console with autologin.

    After reboot for a long period the screen was black and i thought this made it worse somehow but after a while the machine rebooted itself one more time and this time the gui was back to normal with the correct icons displaying again. 

    The only issue i noticed was that once the gui is about to load up a popup comes which asks to Restore the pages because it detected an incorrect shutdown of chromium. If you press the restore button the pop up goes away but it seems to come up after each reboot. So this is also slightly annoying.

    After this i did a manual reboot from within the web interface to see if the settings stick. The setting stick however the reboot process is much much longer then normal. It first goes to the same black screen as mentioned before where it stays for about a minute or 2 then it reboots itself and the printer again after which the gui comes back with the above mentioned pop up issue.

    So this fix seems to work partially but introduces other issues (restore popup and much longer boot and reboot time) apperantly.
  • Update: So after a couple of reboots the icons switched back again to the wrong ones INCLUDING the pop up as mentioned before. Boot times are now also still shitty :(
  • edited March 17
    So it gets weirder. I have made SD image backup of my server when it was still ver 0.90.7 in November. I also do regular manual backups by copying the Repetier-Server folder from the PI var/lib folder.

    So i now restored my SD card image from november. I booted it up and initially to my suprise the icons were incorrect here now also. I did a restart by mistake and noticed that after restart the icons were back to normal.

    I restored my 0.91.2 folder to the PI but noticed that the gui still said (even after a sudo service RepetierServer stop and sudo service RepetierServer start) that i was on 0.90.7. 

    So i did the update again through the gui which completed normally. After a restart i am back to 0.91.2 and the icons are also now still showing normally as they did in the past. 

    After that i again did a reboot through the gui just to see if the icons again revert to the wrong ones but so far it seems they stick to the normal ones...

    Soooooo i really don't see the common pattern between these happenings that could explain all this....
  • Well updating to stretch seems the easiest and most solid solution at the moment.

    Currently I have put an old V7 on a sd card with the hope to get the error, but it did not happen so far. Guess some component needs to check something in internet and does a modification causing the error. So I guess I have to wait until that happens to see it on my own. Or there is an other thing needed.

    If someone has a normal hdmi output version with the error and cam make an image of the sd card I should get the error I guess. But please send it in private since image will contain your license key even if you disable it.
  • Well for the moment the icon issue seems to be gone anyway but to be on the safe side i have now also upgraded from Jessie to Stretch. We'll see if this issue comes up again.
  • Hallo,
    gibt es was neues zu berichten wie man das Problem sicher beheben kann?

  • Hab diesen thread wohl vergessen. Lösung ist ganz einfach:
    https://www.repetier-server.com/knowledgebase/broken-icons-on-touchscreen/

Sign In or Register to comment.