Slow Printing after updating to 91.0

After updating to version 91.0 from 90.7 printing is slower. 
a file i had printed 3 times bevor now takes 7h instead of 5h. 
Nothing changed but the update. Same file, same printer, same print. 
Just to be sure i printed it twice, same result. 
It is running on a raspberry. 
What could be the reason ?
(after 10.02.19 i updated to 91.0) 



  • Intersting since server just sends the commands without modification. So if you have no pauses all the way - I mean you have 111 minutes of extra pause in the print to waste, I think it is not the server, but the firmware. Do you have uploaded a firmware update? Changed some eeprom settings like acceleration or jerk or max speed which also have big influence on printing time.

    Last possible reason - is speed multiplier still on 100%? If you have set it to 70% you would have told printer to print slower, so that is also a possible reason.
  • I haven't changed anything in the firmware... What i did:
    Sunday afternoon after the last print i started the update... after an hour i checked if the update completed, then i shut down. 
    On Monday morning i started a print, first layer with 60% then 100%. Then i realized that the print took longer than expected. i was sure that the seed multiplier was set to 100% but just to be sure i did the second print. 
    There i tried to set the speed to 60%, 80% 100%.. every time it was visible that the speed changed/ increased.  
    The multiplier was set to 100%...But still the print took longer. 

    Are there any printer settings that could have changed with the update?
    It is the same gcode as bevor.. so different slicer settings can't be the reason. 

    When i have time i could try to setup a sd card with V90.7 do a print and if it is as fast as before once again update to 90.1
    I hesitated to do so because of the configuration, setup of the webcams..  
  • There is one function that can slow down printing, but it is disabled by default. Timelapse can now make snapshots at specific positions which requires extruder to move there and back and also to wait for snapshot to finish. So that would add extra time not calculated for, but you need to check that option. Currently it only works with relative extrusion also this will be fixed by 0.91.1 coming in a few hours I hope.

    Apart from this server will not modify gcode and as I hear you also have no 110 minutes of extra pauses. So Speed multiplier is the only other thing, but you checked that already.

    You can enable logging to see lines get send unmodified. So apart from what I said I see no reason for a slowdown and even timelapse would need a lot of snapshots to get that time and you would have noticed all the extra moves.
  • For about one week now V0.91.2 is running fine.. after a complete clean installation. 
    I don't know what caused the problem, but after flashing V0.91.2 everything is working as expected. 
    Two things i noticed though:

    When exporting a printer configuration it is only possible to import it to an existing printer. After the fresh install it was not possible to directly import a printer config. 

    When an area/ gcode is excluded form printing the layers don't update. Two objects with two different hights. The lower object was excluded. When the lower object "would have been finishend" the layers started counting up again while printing the rest of the higher object. 

    Apart form that i realy like the software, keep up the good work.  

Sign In or Register to comment.