Problem with Timelaps on 0.91.0 Server version.

When i turn on "Enforce position for spanshot" my printer begins to arbitrarily make a long retract, change position, freeze for a few seconds. Then he continues to print but because of the long retract plastic is not served.


  • when I turn off the function- "Enforce position for spanshot" - printing and writing timelaps doing well.
  • Thanks. Checking the log I see you use absolute positioning for extruder and we restore E to the wrong value (total extrusion so far). This makes it worse every layer.
    If you slice with relative extrusion coordinates it would work (which we used, so we did not recognice the problem).
    Alternatively disabling retraction should also work. This is set in printer configuration->Extruder where you defined G10 to be 3mm retract. If this is 0 changing E should be omitted.

    Next update will include a fix for the absolute positioning.
  • Thank you very much :)
  • I tried out this new timelapse feature and set extrusion to be relative in S3D and it worked like a charm. Obviously there are some small issues with the ocasional artifacts due to the nozzle moving away and back to the print and the nozzle oozing a bit but other then that the timelapse looks great.
  • Have you defined in printer configuration a retract to help preventing ooze. They are defined in general extruder parameter and reused by timelapse to reduce ooze.

    One problem is in deed sync of moves and making a snapshot. We wait for position trigger snapshot and add a delay of 0.7 seconds. Have increased to 0.8 for next update. In that time fetching jpg from webcam must be finished or you will see the start of back move.

    Obviously small degredation from extra move will happen. That is the price for a fixed extruder position making it look clean.
  • Bit late with my answer but yes i do have retract and ooze settings in general as well for my prints but obviously with the use of such a timelapse it would need to be tweaked more. The problem is that based on the benchy print i saw that for most of the print the oozing was not even an issue only at the last quarter of the print did some small artifacts start to show up. I guess you either have to be much more aggressive with retract and ooze settings when working with this timelapse mode and risk possible underextrusion maybe or spend some time to finetune the ideal settings per material for this mode. 

    Either way its obviously not the fault of the timelapse mode which works great. So thanks for that!

  • You can also increase move xy speed. That is used to move to timelapse position. That would reduce time a bit. Bit is is in deed a longer move so here a more aggressive retract might help, also I'm not sure. Main function of retract is to remove pressure. You can not pull up molten plastic completely so at some point it makes no sense.

    An other trick is to set camera position closer to object, but then you need to tweak it every time. Guess we can not have everything here.
Sign In or Register to comment.